OiL light flashing - Page 3 - Victory Forums - Victory Motorcycle Forum
 6Likes
Reply
 
LinkBack Thread Tools Search this Thread Display Modes
post #21 of 22 (permalink) Old 06-11-2019, 01:00 AM
Junior Member
 
Join Date: Jun 2019
Posts: 4
Default

Washed my bike Saturday. Rode into town Sunday. When I fired it up for the ride home, the light was on. Oil level was o.k. I rode it home with the light on. No problems. Did an oil change today. Light still on. If I disconnect the wire, the light goes out. 99 V92C with low miles.
SmokeRoss is offline  
Sponsored Links
Advertisement
 
post #22 of 22 (permalink) Old 06-11-2019, 07:52 AM
Senior Member
 
Join Date: Sep 2014
Location: Hendersonville, NC in summers and The Villages, FL in winters
Posts: 1,460
Default

Oil lights normally come on due to low oil pressure not low oil volume. Could your oil pump be failing?

G'day,

Vinish

Our patriotic stable:

Red 2012 XCT (wife's bike in NC)
Red 2012 XCT (my bike for NC)
White with custom flames 2012 XCT (wife's bike in FL)
Blue custom fire on a black 2012 XCT (my bike in FL)

2006 HD Softail Heritage (my bike when I was in MI - sold in Oct, 2017 after putting 45,000 miles and 20 states and one province on it - My first big bike and most of us will always remember our first with fond memories)
Vinish is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Victory Forums - Victory Motorcycle Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome