2004 V92 TC doesn't fire up. It was perfect 2 days ago. HELP! - Victory Forums - Victory Motorcycle Forum
 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 10 (permalink) Old 06-24-2014, 12:47 AM Thread Starter
Junior Member
 
Join Date: Jun 2014
Posts: 7
Default 2004 V92 TC doesn't fire up. It was perfect 2 days ago. HELP!

Hi there. 2004 TC just hit 10K miles, and my brother bought it with 7K miles about 4 years ago. It had the 'stage 1' when purchased, with the K&N filter, and the loud pipes. Don't know if the ECU is different or not. Bike had everything replaced 1K miles ago: spark plugs, all fluids (including brake fluid), new tires, everything lubed and adjusted, and was running perfectly. Tried to fire it up today, after sitting in the garage for the weekend, and absolutely no sign of firing up. Cranks fine, but no fire. No sense in burning the starter. Checked relays and fuses, and all fine. Checked all connectors and fine too. Everything sounds normal prior to cranking the engine, meaning fuel pump is priming, etc.

I'd greatly appreciate any help. I'd like to start with a service manual to see if there's a troubleshooting guide for this symptom. And my first question is where can I find a .pdf one? It must be available for free by now, no?

Second question is if there's a known issue with these bikes that could be causing this. Since bike was perfect 2 days ago, I'm eliminating the injectors and coils. Therefore, my money is on the ECU or a critical engine sensor. I'm going to call the 2 local dealers to see if it's possible to just check the ECU by itself, since I don't want to spend a ton on having to flat-bed the bike, and be at their mercy on troubleshooting charges. If one of the critical sensors is bad, a hard code shouldn't be erased, and dealer would be able to read it, right? All comments and advice welcome. Would like to tackle this issue myself first. Thank you folks.
elp_jc is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 06-24-2014, 10:48 AM
Senior Member
 
visionjohnny's Avatar
 
Join Date: Sep 2010
Location: minnesota
Posts: 12,946
Default

First off put bike battery on a tender so it has a full charge

when you turn the key on do you her fuel pump run. Should have a hum sound for a few seconds. If you hear no sound or even if you do you have to check fuel pump for pressure it should be 50psi. Any thing less by 5 pounds pump is shot

With a 10mm wrench check battery bolts to see if there tight.

2008 Vision
Mpls, MN.

Please add your state and model of bike you have. Click user CP @ top of page and then far left click edit signature. Thanks
visionjohnny is offline  
post #3 of 10 (permalink) Old 06-24-2014, 01:05 PM Thread Starter
Junior Member
 
Join Date: Jun 2014
Posts: 7
Default

Quote:
Originally Posted by visionjohnny View Post
First off put bike battery on a tender so it has a full charge. Check fuel pump for pressure it should be 50psi. Any thing less by 5 pounds pump is shot.
Forgot to say battery was fully charged (crank speed is perfectly fine). And as I mentioned, fuel pump primes when ignition is turned on as well. Will have to check for pressure, but how likely is that it sounds fine and it's not? Bike should at least idle even if pressure is low, no? I'd understand high rpm/load bogging with less than ideal fuel pressure, but bike should start IMO.

Any idea where I can get a copy of the service manual?
elp_jc is offline  
Sponsored Links
Advertisement
 
post #4 of 10 (permalink) Old 06-24-2014, 01:12 PM
Super Moderator
 
broggyr's Avatar
 
Join Date: Apr 2013
Location: Naugatuck, CT
Posts: 6,302
Garage
Default

Check BBob's post about manuals and see if yours is in there.

https://www.victoryforums.com/showpos...40&postcount=1



2013 XCT, Boardwalk Blue w/ Vicwrapz
S&S Cams, Lloydz filter & ATS +5, PCV, UD pulley, Alto Red Eagle clutch plates
Madstad Windshield, 5000K HID, TriOvals, Memphis Shields wings, Ultimate seat
JVC KD-X35MDT, PBR300X4, Polk DB6502, DaytonAudio ND140-4 rear
HyperLites, LED driving lights, Lloydz dyno 105+H and 117+T
Arlen Ness blinkers, KlockWerks KlipHanger bars, Avon grips

Spectro Golden 4 20w40 for Victory L.SG424, Kury Sabertooth LEDs
THE FEW, THE PROUD, THE OBSCURE. TTWFO2
broggyr is offline  
post #5 of 10 (permalink) Old 06-24-2014, 02:52 PM Thread Starter
Junior Member
 
Join Date: Jun 2014
Posts: 7
Default

Quote:
Originally Posted by broggyr View Post
Check BBob's post about manuals and see if yours is in there.
The 2004 wasn't included, but found it under 2002-2004 V92s, and the TC is in there. Thanks a million. No general troubleshooting guide, but found the 'crank, but no start' troubleshooting guide under the 'fuel system' section, and there a crapload of things that could be wrong. I could eliminate several fuel related issues by measuring what the injectors pour in 'x' time. Remember seeing that somewhere (maintenance?). But need to make sure no special tools are required. Several others won't apply to me like clogged filters, etc., since bike was working perfectly just 2 days ago. The final wave of possibilities are sensors and the ECU, but both local dealers want the bike to test it, and if nothing appears from their computer hookup, charges might go up like smoke. Both said no known component failures that would render the bike uselsss on the TC; they're very reliable.

Will keep you guys posted, and in the mean time, if any of you have heard of any possible culprit, please shoot .
elp_jc is offline  
post #6 of 10 (permalink) Old 06-24-2014, 05:09 PM
Senior Member
 
visionjohnny's Avatar
 
Join Date: Sep 2010
Location: minnesota
Posts: 12,946
Default

do you have spark. Pul spark plug rest it on a metal part of motor of with some wood hold it to motor. It will give you a shock. If you have spark then do a fuel pump test. If you pull pugs and there wet you will need new ones. All so if there wet your not getting spark.



2008 Vision
Mpls, MN.

Please add your state and model of bike you have. Click user CP @ top of page and then far left click edit signature. Thanks
visionjohnny is offline  
post #7 of 10 (permalink) Old 06-25-2014, 06:11 PM Thread Starter
Junior Member
 
Join Date: Jun 2014
Posts: 7
Default

Quote:
Originally Posted by visionjohnny View Post
If you have spark then do a fuel pump test.
Thanks a lot for that video. Didn't realize this bike had the schaeder valve for the fuel; will look for it later today. And will also call AutoZone to see if they have a fuel pressure gauge. Might as well rent a compression one since I'll have the plugs out anyway. If fuel pump is fine and there's spark, then I'd be dealing with a bad sensor (95% chance IMO) or computer (5% chance)... meaning I'd have to take the freaking bike to a dealer anyway. Will keep you folks posted, and thank you for all the help .
elp_jc is offline  
post #8 of 10 (permalink) Old 07-08-2014, 08:53 PM Thread Starter
Junior Member
 
Join Date: Jun 2014
Posts: 7
Default

Well, it was the freaking fuel pump; don't understand why it seemed to be working, and not even enough pressure to hold idle. Oh well. Anyway, dealer wants $600 for the pump, plus $450 labor to replace it. That's out of the question. I'd appreciate any links to discount dealers or places to buy the pump. Will check the service manual to see how easy of a job is, and also get quotes from independent mechanics. But need a new pump for sure. Thanks gang.
elp_jc is offline  
post #9 of 10 (permalink) Old 07-08-2014, 10:48 PM
Senior Member
 
Speeddemon3579's Avatar
 
Join Date: Sep 2012
Location: middle, tn
Posts: 545
Default

This should help your wallet sir. https://www.victoryforums.com/showthread.php?t=86329

2000 V92SC
Middle Tenn
it ain't stock...

2000 V92SC
Rock Island,TN
If I can't buy it, I make it.
Just Getting Started
Speeddemon3579 is offline  
post #10 of 10 (permalink) Old 07-09-2014, 12:06 PM
Senior Member
 
visionjohnny's Avatar
 
Join Date: Sep 2010
Location: minnesota
Posts: 12,946
Default

elp_jc

if you can get the pump out Rylan at the Vic shop rebuilds them.

2008 Vision
Mpls, MN.

Please add your state and model of bike you have. Click user CP @ top of page and then far left click edit signature. Thanks
visionjohnny is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Victory Forums - Victory Motorcycle Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome