07 JP; cleaned throttle bodies now it runs terrible? - Victory Forums - Victory Motorcycle Forum
Reply
 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 13 (permalink) Old 07-27-2016, 07:00 AM Thread Starter
Member
 
slave600's Avatar
 
Join Date: May 2012
Location: charlotte nc
Posts: 75
Default 07 JP; cleaned throttle bodies now it runs terrible?

so I cleaned the TB last night and it had a fair amount of gunk in there... now its nice and shiny.
Sadly in the process of checking the air intake boot (the whole reason I was even in there) I seem to have created or exacerbated a problem.
The bike starts fine and runs a bit erratic, but what has me perplexed is that when I rev the bike up it will linger at a higher rpm for varying amounts of time. The first few twists of the throttle had it "stick" for a few seconds at most... now it lingers for a solid minute or two.
I lubed the throttle linkage at the TB, checked the arrangement of the cables for kinks, and even reset the baseline of the TPS!

I wonder if the bike was "programmed" or had the TPS adjusted (with the digital wrench system by the dealership before I purchased) with the gummed up TB....... would that cause the lingering higher rpms???

maybe the computer is giving it more fuel where it used to be starved? now that its nice and clean it is confused???

07 Vic. V. Jackpot
-RPW big slash
-K/N filter w/ vented airbox

04 Vic. Vegas
-twin turn downs
-vented airbox
slave600 is offline  
Sponsored Links
Advertisement
 
post #2 of 13 (permalink) Old 07-27-2016, 01:45 PM
Senior Member
 
visionjohnny's Avatar
 
Join Date: Sep 2010
Location: minnesota
Posts: 12,871
Default

your cables could be out of the groves at the throttle body. With the motor off twist the throttle and let go. It should snap back instantly and the pull should be smooth. If not pull tank and look cables over. While you're there check the little vacuum caps for cracks auto store sells them.
Don't know about the TPS

2008 Vision
Mpls, MN.

Please add your state and model of bike you have. Click user CP @ top of page and then far left click edit signature. Thanks
visionjohnny is offline  
post #3 of 13 (permalink) Old 08-01-2016, 06:50 AM Thread Starter
Member
 
slave600's Avatar
 
Join Date: May 2012
Location: charlotte nc
Posts: 75
Default

definitely not the cables... they are functioning and run properly. I'm guessing that some part of my process may have affected the map card or even confused the TPS somehow? Hence the elaborate original post.... I am hoping a Victory pro sees an issue with my procedure and that I did something wrong and not this gremlin that makes no sense to me

07 Vic. V. Jackpot
-RPW big slash
-K/N filter w/ vented airbox

04 Vic. Vegas
-twin turn downs
-vented airbox
slave600 is offline  
Sponsored Links
Advertisement
 
post #4 of 13 (permalink) Old 08-01-2016, 07:38 AM
Lifetime Premium
 
half_crazy's Avatar
 
Join Date: Sep 2011
Location: Southern Maryland
Posts: 4,791
Default

Sounds like a vacuum leak. Maybe the gunk was sealing it up.
Did you check the cap-offs on the throttle body?
Attached Images
File Type: jpg $_57.jpg (27.6 KB, 7 views)

2006 Victory Kingpin
Lloydz 116" Stroker/Big Bore, .495 Cams, Torque Tubes Airbox,
RPW Thor Pipe, Lloydz ECU Flash, PC-III, PTS (-2), Rivera
Primo Clutch Spring, 31 Tooth Pulley w/Buell Belt.
half_crazy is offline  
post #5 of 13 (permalink) Old 08-01-2016, 07:42 AM
Senior Member
 
Konga63's Avatar
 
Join Date: Jan 2014
Location: Centre County, PA
Posts: 742
Garage
Default

The first time I cleaned my TB's I experienced something similar. My bike ran like shit too. Maybe you dislodged some crap and fouled your plug(s)? I changed my plugs after scratching my head and the bike ran fine. Hope you get this resolved.

2007 Ness Jackpot

Last edited by Konga63; 08-04-2016 at 11:14 AM.
Konga63 is offline  
post #6 of 13 (permalink) Old 08-01-2016, 08:36 AM
Member
 
raptout's Avatar
 
Join Date: May 2014
Location: Quad Cities, Iowa
Posts: 40
Default

I second HC's air leak theory. Any way to squirt carb cleaner around the boots while it is idling? That may help identify the leak

2008 Vegas 8-Ball
Victory Stage 1
raptout is offline  
post #7 of 13 (permalink) Old 08-01-2016, 11:58 AM Thread Starter
Member
 
slave600's Avatar
 
Join Date: May 2012
Location: charlotte nc
Posts: 75
Default

I will tear it down again this evening.... to heck the caps again (they can be sprayed easily with the right side wedge removed)

I'm curious if anyone knows of a member or shop that can perform the computer work (tps adjustment, map card, tune) in the charlotte area??? interstate cycle has a ton of knowledge but they cannot acquire the cables to link up to the 92 or 100ci motors!!!!

07 Vic. V. Jackpot
-RPW big slash
-K/N filter w/ vented airbox

04 Vic. Vegas
-twin turn downs
-vented airbox
slave600 is offline  
post #8 of 13 (permalink) Old 08-01-2016, 12:00 PM Thread Starter
Member
 
slave600's Avatar
 
Join Date: May 2012
Location: charlotte nc
Posts: 75
Default

anyone know a good shop that can perform computer related services on the 04 92ci and the 07 100ci motors near charlotte nc??

the best shop I have locally cant acquire the cables to use digital wrench!!!

07 Vic. V. Jackpot
-RPW big slash
-K/N filter w/ vented airbox

04 Vic. Vegas
-twin turn downs
-vented airbox
slave600 is offline  
post #9 of 13 (permalink) Old 08-01-2016, 04:50 PM
Member
 
raptout's Avatar
 
Join Date: May 2014
Location: Quad Cities, Iowa
Posts: 40
Default

do you have a power commander on it? If so you can check the TPS % throttle with your laptop- otherwise you can unplug the TPS harness and check the OHM reading. If you are able to stab the wires you can check the voltage across two of the 3 wires also. The reading can be compared the books prescribed range of values that would be acceptable.

Try spraying carb cleaner first before you tear anything apart and see if that tells you anything.

2008 Vegas 8-Ball
Victory Stage 1
raptout is offline  
post #10 of 13 (permalink) Old 08-01-2016, 05:42 PM
Senior Member
 
visionjohnny's Avatar
 
Join Date: Sep 2010
Location: minnesota
Posts: 12,871
Default

maybe some help

https://thebikersgarage.wordpress.co...-a-motorcycle/

2008 Vision
Mpls, MN.

Please add your state and model of bike you have. Click user CP @ top of page and then far left click edit signature. Thanks
visionjohnny is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Victory Forums - Victory Motorcycle Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome