New member - Victory Forums - Victory Motorcycle Forum
 1Likes
  • 1 Post By Old Soldier
 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 7 (permalink) Old 10-13-2018, 06:21 AM Thread Starter
New Member
 
Join Date: Oct 2018
Posts: 1
Default New member

Hello ya'll from south Texas, my father in law gave my wife and i a 2003 touring classic, absolutely beautiful bike, I'm trying to get her back on the road, haven't rode her in a while due to my job but I'm having real problems with her running rough at around 1700-2000 rpm's. I've changed the TPS and the fuel pump and now she won't even fire off. Any words of advice will be greatly appreciated. Thanks in advance and God bless!
Brwall is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 10-13-2018, 06:41 AM
Lifetime Premium
 
BP6666VR's Avatar
 
Join Date: Dec 2013
Location: World Citizen = A peaceful and peacemaking individual, both in daily life and contacts with others
Posts: 5,851
Default

Quote:
Originally Posted by Brwall View Post
Hello ya'll from south Texas, my father in law gave my wife and i a 2003 touring classic, absolutely beautiful bike, I'm trying to get her back on the road, haven't rode her in a while due to my job but I'm having real problems with her running rough at around 1700-2000 rpm's. I've changed the TPS and the fuel pump and now she won't even fire off. Any words of advice will be greatly appreciated. Thanks in advance and God bless!
How many miles did you do with running rough ?

Andre using TaPaTaLk

JACKPOT 2013 orange MADNESS :-) *HOH-VM1-DR*TachoMeter*PowCom-5*AutoTune*ATS*TorTube & (IAC) & nitro*Swept exhaust*LYNDALL & EBC brakes Front & Rear*Stainless Beads*Fwd Contr 4" *2 x Bad Boy Air Horn*Seven Color Lizard*NGK plugs*Blue Spark Plug Wir*Victory Oil*KN Oil filter*Oil Analysis*Clutch Cover*Kickst Repl Rubb*Invisble-A-Key*L.E.D. Batt. Gauge*Pulsating Brake Light*VictoryHID*Lice Bracket OVAL*BoltKit-Chrome*

Cross Country Tour 2014 [B]
BP6666VR is offline  
post #3 of 7 (permalink) Old 11-15-2018, 04:58 PM
Junior Member
 
Join Date: Nov 2018
Posts: 3
Default

Quote:
Originally Posted by Brwall View Post
Hello ya'll from south Texas, my father in law gave my wife and i a 2003 touring classic, absolutely beautiful bike, I'm trying to get her back on the road, haven't rode her in a while due to my job but I'm having real problems with her running rough at around 1700-2000 rpm's. I've changed the TPS and the fuel pump and now she won't even fire off. Any words of advice will be greatly appreciated. Thanks in advance and God bless!
Since you had the fuel tank off to replaced the electric fuel pump on the underside rear of the tank, and had the air box off or at least unbolted from the throttle bodies, did you go back and check all of your connectors, including to the ignition coil pack and the throttle position sensor? When you turn the ignition on, do you hear the fuel pump run so it can prime the fuel system? If not, check that you properly connected the harness plug to the fuel pump. If the fuel pump does prime, did you check the fuel line that runs from the fuel pump to the fuel pressure regulator/fuel rail? It may have gotten twisted before you reconnected it after putting the fuel tank back on. It's best to disconnect it at the fuel pressure regulator before removing the fuel tank.
RICZ likes this.
Old Soldier is offline  
Sponsored Links
Advertisement
 
post #4 of 7 (permalink) Old 11-15-2018, 10:17 PM
Senior Member
 
RICZ's Avatar
 
Join Date: Sep 2010
Location: Portland,Oregon
Posts: 11,952
Default

Check for spark, but be vewy, vewy careful. Are the battery connections clean and tight? They have a tendency to loosen. Best to place lock washers under the bolt heads.
A call to Kevin Cross or Rylan Vos at the Vic Shop might help.

2010 Midnight Cherry XR. 7Jurock, Lloydz AF, ATS, AFR tuned VFCIII, IAV, and T-6 and locally repacked pipes = big smiles. SOLD to a dear friend, so it's still in the family."
2017 Spyder F3 Limited - keeps this old guy in the wind and riding with friends.
Cure that ugly stand up license plate with the cheapest and best laydown bracket. Click this:
https://www.victoryforums.com/11-ven...t-x-bikes.html
RICZ is offline  
post #5 of 7 (permalink) Old 11-16-2018, 02:01 PM
Senior Member
 
visionjohnny's Avatar
 
Join Date: Sep 2010
Location: minnesota
Posts: 12,868
Default

you can find your manual here download to your computer. If you don't know how to check for spark look on youtube there is a bunch there



https://www.mediafire.com/folder/aoq...ictory_Manuals

2008 Vision
Mpls, MN.

Please add your state and model of bike you have. Click user CP @ top of page and then far left click edit signature. Thanks
visionjohnny is offline  
post #6 of 7 (permalink) Old 11-16-2018, 08:25 PM
Senior Member
 
Join Date: Feb 2018
Location: San Diego
Posts: 155
Garage
Default

My 2010 Jackpot ran pretty rough when I got it, but I knew it had been stored for a while. The first thing I did was change the oil and clean out the air intake. Made a world of difference. You may have crud built up in the oil pump, and residue in the throttle body.

2010 Jackpot, 19k miles, Torque Tube, Bassani and more.
BadBoyZ is offline  
post #7 of 7 (permalink) Old 11-16-2018, 08:26 PM
Senior Member
 
Join Date: Feb 2018
Location: San Diego
Posts: 155
Garage
Default

Also had a problem with a collapsed fuel line. That rubber under the tank gets a lot of heat.

2010 Jackpot, 19k miles, Torque Tube, Bassani and more.
BadBoyZ is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Victory Forums - Victory Motorcycle Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome