Hello - Victory Forums - Victory Motorcycle Forum
 2Likes
  • 1 Post By Ronnie Dale Gebhart
  • 1 Post By RoteBaron
 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 6 (permalink) Old 06-01-2019, 01:41 AM Thread Starter
Junior Member
 
Ronnie Dale Gebhart's Avatar
 
Join Date: Jun 2019
Posts: 3
Default Hello

Thanks for adding me
Ronnie Dale Gebhart is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 06-01-2019, 05:40 AM
Senior Member
 
CanuckRob's Avatar
 
Join Date: Sep 2017
Location: Elmvale ON., Canada
Posts: 491
Garage
Default

Hey Ronnie,

Welcome to the forum from Elmvale ON Canada.... What's your ride? Where are you ?

Ride Safe,

Rob

2010 Cross Country -
Elmvale ON Canada

Stage 1
Chrome Tri Ovals
Lloyds 1/4 turn throttle ring
Kuryakyn heel toe shifter
OEM high performance air filter
CanuckRob is offline  
post #3 of 6 (permalink) Old 06-01-2019, 06:55 AM Thread Starter
Junior Member
 
Ronnie Dale Gebhart's Avatar
 
Join Date: Jun 2019
Posts: 3
Default

My ride is 2003 Victoryclassic Cruiser , it died on me while I was riding , compression is good , getting fire , spark is good , fuel pump is good , it's wanting to start but it's not , on the throttle body ports are not caped should they be
CanuckRob likes this.
Ronnie Dale Gebhart is offline  
Sponsored Links
Advertisement
 
post #4 of 6 (permalink) Old 06-01-2019, 07:27 AM
Senior Member
 
CanuckRob's Avatar
 
Join Date: Sep 2017
Location: Elmvale ON., Canada
Posts: 491
Garage
Default

hmmm I'm not sure on that one...but I'm certain someone will jump in soon with some suggestions....good luck with it...

Rob

2010 Cross Country -
Elmvale ON Canada

Stage 1
Chrome Tri Ovals
Lloyds 1/4 turn throttle ring
Kuryakyn heel toe shifter
OEM high performance air filter
CanuckRob is offline  
post #5 of 6 (permalink) Old 06-02-2019, 08:08 AM
Senior Member
 
RoteBaron's Avatar
 
Join Date: Aug 2013
Location: South Eastern Wyoming
Posts: 296
Garage
Default 3 things needed

There are 3 things needed - 1. Air, b. fuel, and 3. electricity. Sounds like you probably have them so it would seem there might be a deficiency in one. !st check the battery connections and ensure they are good. Also consider checking the battery itself. Vics are notorious for battery problems. I'm a keep it simple trouble shooter. Check and make sure its getting electricity to both plugs. Then again, since it failed while riding it may be something else but check for air leaks. There are things like a 40 amp fuse and a some sensors that could go bad but again, check the basics first. Not easy to trouble shoot without being there. Hope this helps. LMYR

P.S. There are some manuals available here that may help - https://www.mediafire.com/folder/aoq...ictory_Manuals
CanuckRob likes this.

Long may you ride!

RB
2013 Vision Sunset Red
Lloydz Timing wheel @ 3deg (Soon to go)
Victory High Flow Air Filter
Soon to tune with Maximus

2017 Highball - Suede Nuclear Sunset Orange
Xbow exhaust, High flow air filter, Lame stage 1 update (MEH)
Soon to tune with Maximus
RoteBaron is offline  
post #6 of 6 (permalink) Old 06-02-2019, 11:28 PM Thread Starter
Junior Member
 
Ronnie Dale Gebhart's Avatar
 
Join Date: Jun 2019
Posts: 3
Default

Thanks for your Info , well I replaced throttle body adapter , and there are 2 ports on the side of throttle body, are any of the 2 ports supposed to be capped off or not ?
Ronnie Dale Gebhart is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Victory Forums - Victory Motorcycle Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome