confused - Victory Forums - Victory Motorcycle Forum
 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 5 (permalink) Old 04-12-2014, 06:26 AM Thread Starter
New Member
 
Join Date: Apr 2014
Posts: 1
Default confused

Ok new to the forum. Im having an issue on my 01. Battery died over winter. Jumped it with my truck it started. Speedo and tac worked fine. Died so I got new battery. Installed it and bam my Speedo don't work, gas light and oil light stays on, and tac not working. Please help!! Thanks
galvin is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 04-12-2014, 08:13 AM
Lifetime Premium
 
saddlebag's Avatar
 
Join Date: Jun 2011
Location: Dayton, Ohio
Posts: 5,632
Default

Quote:
Originally Posted by galvin View Post
Ok new to the forum. Im having an issue on my 01. Battery died over winter. Jumped it with my truck it started. Speedo and tac worked fine. Died so I got new battery. Installed it and bam my Speedo don't work, gas light and oil light stays on, and tac not working. Please help!! Thanks
Are you sure the new battery was properly charged?

It's been my experience that a malfunctioning or improperly connected voltage regulators will cause instruments to flake out, but if yours worked last year before you put the bike away, that probably isn't your problem.




https://www.victoryforums.com/signaturepics/sigpic6903_1.gif
2011 Cross Roads
saddlebag is offline  
post #3 of 5 (permalink) Old 04-12-2014, 09:13 PM
Senior Member
 
RICZ's Avatar
 
Join Date: Sep 2010
Location: Portland,Oregon
Posts: 12,122
Default

I see (possibly) two strikes here; Jumping from a truck--too much amperage and buying a battery and installing it without fully charging it beforehand.

2010 Midnight Cherry XR. 7Jurock, Lloydz AF, ATS, AFR tuned VFCIII, IAV, and T-6 and locally repacked pipes = big smiles. SOLD to a dear friend, so it's still in the family."
2017 Spyder F3 Limited - keeps this old guy in the wind and riding with friends.
Cure that ugly stand up license plate with the cheapest and best laydown bracket. Click this:
https://www.victoryforums.com/11-ven...t-x-bikes.html
RICZ is offline  
Sponsored Links
Advertisement
 
post #4 of 5 (permalink) Old 04-13-2014, 11:50 AM
Senior Member
 
visionjohnny's Avatar
 
Join Date: Sep 2010
Location: minnesota
Posts: 12,949
Default

If you ever jump off car or truck make sure that motor is not running

2008 Vision
Mpls, MN.

Please add your state and model of bike you have. Click user CP @ top of page and then far left click edit signature. Thanks
visionjohnny is offline  
post #5 of 5 (permalink) Old 04-13-2014, 08:08 PM
Senior Member
 
TheBigBK's Avatar
 
Join Date: Feb 2013
Location: Halifax, NS
Posts: 530
Default

My brain went to "hope the truck wasn't running when you jumped it"...I don't know much, but i know what i know...and i know this from learning the hard way.

theBIGbk
2013 Judge
Long live the oval
TheBigBK is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Victory Forums - Victory Motorcycle Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome