New User and question - Victory Forums - Victory Motorcycle Forum
 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 3 (permalink) Old 05-20-2014, 07:48 PM Thread Starter
Junior Member
 
Join Date: Nov 2013
Location: Fayetteville, NC
Posts: 3
Default New User and question

Steve D here, I have an 01 V92 C with 42K miles, It was rough running and I saw the postings on changing out the TPS and have done that and reset the throttle. I have had a new fuel pump, filter, plugs, cleaned the air filter. It is fine at idle (950-1000), but when you give it any throttle and it hits 2500 RPM it bogs down and sounds like it wants to stall out. PLEASE HELP!!!!!!
Steve_D is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 05-20-2014, 09:00 PM
Senior Member
 
visionjohnny's Avatar
 
Join Date: Sep 2010
Location: minnesota
Posts: 12,947
Default

did you clean the throttle body

http://buywitchdoctors.com/c/762/vic...-instructions/

2008 Vision
Mpls, MN.

Please add your state and model of bike you have. Click user CP @ top of page and then far left click edit signature. Thanks
visionjohnny is offline  
post #3 of 3 (permalink) Old 05-20-2014, 09:19 PM Thread Starter
Junior Member
 
Join Date: Nov 2013
Location: Fayetteville, NC
Posts: 3
Default

Yeah, I cleaned them, then took them to my local shop where they were electrostatically cleaned. No dice.
Steve_D is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Victory Forums - Victory Motorcycle Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome