2005 V92TC Fuel Gauge Issue - Victory Forums - Victory Motorcycle Forum
 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 3 (permalink) Old 06-10-2014, 02:02 PM Thread Starter
Junior Member
 
Colonel's Avatar
 
Join Date: Mar 2013
Location: Tennessee
Posts: 16
Default 2005 V92TC Fuel Gauge Issue

Went out to ride a couple of days ago, when I started my Vic, I noticed the small gas pump flashing in the lower right corner of my MFD and my gauge showed. LO FUEL...but I had a full tank. Cannot find any reason why this is suddenly happening. Any ideas out there?
Colonel is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 06-10-2014, 10:33 PM
Senior Member
 
Oldman47's Avatar
 
Join Date: Mar 2013
Location: Central Illinois
Posts: 1,414
Default

On my '13 Vision I get to see that symbol any time I have less than 1/2 tank of fuel. With the bike on the side stand the gas gauge is more or less out of the main part of the fuel so I see that low fuel thing a lot. As soon as I stand to bike up straight the gauge reads more like the real fuel level and the yellow symbol goes out.

Present ride - 2013 Victory Vision, black, ATW at +3, Lloydz air filter and adjustable intake, PC5, 30,xxx miles
Oldman47 is offline  
post #3 of 3 (permalink) Old 06-11-2014, 07:39 AM Thread Starter
Junior Member
 
Colonel's Avatar
 
Join Date: Mar 2013
Location: Tennessee
Posts: 16
Talking Fuel Gauge Problem

[/LEFT]
Quote:
Originally Posted by Oldman47 View Post
On my '13 Vision I get to see that symbol any time I have less than 1/2 tank of fuel. With the bike on the side stand the gas gauge is more or less out of the main part of the fuel so I see that low fuel thing a lot. As soon as I stand to bike up straight the gauge reads more like the real fuel level and the yellow symbol goes out.
Thanks for the reply...you are correct and normally I get the same results when kick stand is down and it goes away once upright and moving. BUT my blinking "fuel pump icon" and LO FUEL message are remaining ON even after being up and going. A Vic dealer told me yesterday it was most likely my fuel pump and would cost $239 for the part plus labor.
Colonel is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Victory Forums - Victory Motorcycle Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome