Problem with my 2002 V92TC Motorcycle. - Victory Forums - Victory Motorcycle Forum
 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 3 (permalink) Old 08-27-2018, 07:46 PM Thread Starter
New Member
 
Join Date: Aug 2018
Posts: 1
Default Problem with my 2002 V92TC Motorcycle.

Hey new to this site,
Looking for some advise and help with my V92TC Cruizer.

The problem is that the Speedo is acting up on my bike. What is happening is that the (MFD) Multi function display is going blank along with the speedometer and the Tach are freezing at what ever the speed is and when they are working all is fine. BUT usually find that MFD and speedometer and tach all go at the same time, prematurely and do not know what to do to solve this problem ?

Just wondering what do to solve this problem or is there a replacement speedo to get to replace this one. Victory does not make this part anymore. Not sure what to do to repair this problem ?

Any suggestion ??

René
René Pottie is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 08-28-2018, 01:59 PM
Senior Member
 
visionjohnny's Avatar
 
Join Date: Sep 2010
Location: minnesota
Posts: 12,947
Default

Write Rylan he is a expert on the early model bikes

[email protected]

2008 Vision
Mpls, MN.

Please add your state and model of bike you have. Click user CP @ top of page and then far left click edit signature. Thanks
visionjohnny is offline  
post #3 of 3 (permalink) Old 08-31-2018, 07:52 PM
Member
 
SportyDoug's Avatar
 
Join Date: Jun 2018
Location: Silver City, NM
Posts: 46
Default

Hi, Rene.

Sounds like a loose connection somewhere. The reason I say that is because, if I understand correctly, the system works intermittently. The turn signals on my 04 v92tc stopped working and I assumed it was the Turn Signal/Hazard Flasher. I set about testing the thing and then lost all fire to the turn signal bulbs. I checked wires and connections for some time and one day, while working on the bike and talking to my wife the lights came back on. They did not blink but came back on. SHORT. The first harness I had moved was the one connecting to the Flasher. After a quick look I saw the ground wire broken at the connector. Some solder and a replacement Turn Signal/Hazard Flasher and I was back in business.

It helps to have the manual.

You may be able to find a used working speedo on eBay, but they are often pricey.

Good luck with it. A friend who was an electrician once told me that all mechanics think electricity is magic. To which I replied, "Yes! And we don't like it".

Warm regards,
Doug
SportyDoug is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Victory Forums - Victory Motorcycle Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome