Electrical problem 2007 Hammer - Victory Forums - Victory Motorcycle Forum
 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 6 (permalink) Old 06-30-2015, 05:45 AM Thread Starter
Member
 
Join Date: Jun 2015
Posts: 57
Default Electrical problem 2007 Hammer

Hey guys. Previous owner lowered the bike and had 0 preload on the shock and never had a passenger on the bike. You can guess what happened. Had my girlfriend on the bike and the tire rubbed the wires. Blew the 15A fuse and i took the fender off and fixed it. This happened a second time after adding a bunch of preload. Only this time the left turn signals arent working at all. It flashes on the cluster and thats it. Even with the rear fender plug off the front left turn signal doesnt work. Everything else appears to be working fine. I did make the mistake of putting a 25A fuse in where it was a 15A because its all i had and i wanted to see if it was working the first time i fixed it, and i forgot about it. So far i've separated all the wires and wrapped them in electrical tape where they were bare. I'm thinking its a ground issue, even though according to the schematic the right turn signals share the same ground. Also, i've checked to make sure the bulbs weren't burnt out. Any help would be appreciated, thanks.
OhioPatriot308 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 06-30-2015, 05:54 AM
Lifetime Premium
 
kevinx's Avatar
 
Join Date: Dec 2009
Location: At Southern Motorworx. High Springs Fl
Posts: 2,646
Default

Fried auto cancel module

I'm not an asshole...I just type that way
Check us out at Southern Motorworx on FaceBook
https://www.facebook.com/home.php
http://www.southernmotorworx.com/index.html
kevinx is offline  
post #3 of 6 (permalink) Old 06-30-2015, 06:50 AM Thread Starter
Member
 
Join Date: Jun 2015
Posts: 57
Default

Yea just discovered that after doing some searching Its always something. Live and learn. Have you ever heard of someone repairing one? Especially if everything else works. Its just really painful to fork out $250 for something that doesnt add horsepower
OhioPatriot308 is offline  
Sponsored Links
Advertisement
 
post #4 of 6 (permalink) Old 06-30-2015, 11:47 AM
Senior Member
 
visionjohnny's Avatar
 
Join Date: Sep 2010
Location: minnesota
Posts: 12,928
Default

maybe this
http://www.jpcycles.com/product/381-...+NON-BRAND+PLA




2008 Vision
Mpls, MN.

Please add your state and model of bike you have. Click user CP @ top of page and then far left click edit signature. Thanks
visionjohnny is offline  
post #5 of 6 (permalink) Old 06-30-2015, 02:06 PM
Lifetime Premium
 
zxmikez's Avatar
 
Join Date: Sep 2010
Location: Albany ny
Posts: 29
Default Aftermarket tail/signal light

Since you are doing surgery, you might want to add this thing:
http://www.mbwmotorcycle.com/products/hammer.html

Definitely cleans up the look of the tail, and eliminates the outboard signals

2007 Hammer Premium
zxmikez is offline  
post #6 of 6 (permalink) Old 07-01-2015, 06:30 AM Thread Starter
Member
 
Join Date: Jun 2015
Posts: 57
Default

Since the ACM is potted i'm going the alternative and hopefully free route and unpot it and find where its fried. You can use a heat gun and an exacto knife to remove the epoxy and eventually get to module. I will take pictures along the way and post results. This could eventually help alot of people
OhioPatriot308 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Victory Forums - Victory Motorcycle Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome