Finally running awesome again - Victory Forums - Victory Motorcycle Forum
 1Likes
  • 1 Post By Shark88
 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 7 (permalink) Old 05-20-2018, 09:03 PM Thread Starter
Member
 
Shark88's Avatar
 
Join Date: Jan 2017
Location: Central PA
Posts: 44
Default Finally running awesome again

When I got my Kingpin last year it really seamed to run a little rough at idle and it seemed that the only way it would idle properly was if I kept the fuel enriched on. Well that all changed today. With the help of a YouTube video I watched from the Vic Shop I pulled the tank and cleaned out the throttle body, buttoned it back up and started her up.
Also, when I had the air box cover off I also checked my fuel enricher adjustment and found it only opened ever so slightly, there was so much slack in the cable I can't believe it moved and opened at all. Before when I started the bike it idled only around 800 rpm and that was with the enricher turned up. Now after I started her it ran about 1400 rpm with the enricher off. I adjusted the Idle to 1000 rpm and took her around the block and it feels smoother and more responsive, I can't wait to open it up on the highway now.
I was running late today getting it back together and I didn't have time to pull the plugs and check them yet, so that's next. I have just over 14,000 on the bike now so I'm not thinking they need changed, but if it wasn't running right all that time I'm thinking they might, we'll see. Ready for the summer now!
Motorbikerx likes this.

2007 Kingpin Tour
Bought Jan 2017 10,800 miles

Last edited by Shark88; 05-22-2018 at 10:15 AM.
Shark88 is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 06-06-2018, 07:46 AM
Member
 
Join Date: Oct 2011
Location: New Jersey
Posts: 97
Default

Quick FYI - It's not an enricher. It's a fast idle lever (per service manual). It's just to hold the throttle open so you idle faster. No enrichening of the idle mixture.

Closed minded people suck.
13 Vic CC
05 HD EG
08 HD RG
John R. is offline  
post #3 of 7 (permalink) Old 06-06-2018, 02:02 PM
Senior Member
 
visionjohnny's Avatar
 
Join Date: Sep 2010
Location: minnesota
Posts: 12,868
Default

If you used a lot of cleaner to clean the throttle body for sure get new plugs. You might even want to get new wires cause factory one are not that good. All so check oil if you used a lot of cleaner it might be over full.

Your #1 Source for US Made, Custom Victory & Indian Motorcycle Parts

2008 Vision
Mpls, MN.

Please add your state and model of bike you have. Click user CP @ top of page and then far left click edit signature. Thanks
visionjohnny is offline  
Sponsored Links
Advertisement
 
post #4 of 7 (permalink) Old 06-08-2018, 02:35 PM Thread Starter
Member
 
Shark88's Avatar
 
Join Date: Jan 2017
Location: Central PA
Posts: 44
Default

Quote:
Originally Posted by visionjohnny View Post
If you used a lot of cleaner to clean the throttle body for sure get new plugs. You might even want to get new wires cause factory one are not that good. All so check oil if you used a lot of cleaner it might be over full.
I did change the plugs with new NGK's, the old ones didn't look too bad. Is there a good vendor for the aftermarket wires? I was at a dealer last year and they had a blue set I thought would look good but they were liste for an 08 & up so I didn't get them.

Your #1 Source for US Made, Custom Victory & Indian Motorcycle Parts
Quote:
Originally Posted by John R. View Post
Quick FYI - It's not an enricher. It's a fast idle lever (per service manual). It's just to hold the throttle open so you idle faster. No enrichening of the idle mixture.
I was wondering about that. It makes sense, Thanks.

2007 Kingpin Tour
Bought Jan 2017 10,800 miles
Shark88 is offline  
post #5 of 7 (permalink) Old 06-08-2018, 02:39 PM Thread Starter
Member
 
Shark88's Avatar
 
Join Date: Jan 2017
Location: Central PA
Posts: 44
Default

Quote:
Originally Posted by visionjohnny View Post
If you used a lot of cleaner to clean the throttle body for sure get new plugs. You might even want to get new wires cause factory one are not that good. All so check oil if you used a lot of cleaner it might be over full.

Your #1 Source for US Made, Custom Victory & Indian Motorcycle Parts
I changed the plugs and the old ones didn't really seem bad. Didn't really notice a difference. Also what is a good vendor for plug wires. I almost bought a set last year at a dealer but they were listed for an 08 & up. Didn't know if there was a difference so I didn't get them.

2007 Kingpin Tour
Bought Jan 2017 10,800 miles
Shark88 is offline  
post #6 of 7 (permalink) Old 06-08-2018, 03:53 PM
Lifetime Premium
 
doobliss's Avatar
 
Join Date: Aug 2013
Location: Canton, Ohio
Posts: 734
Garage
Default

Quote:
Originally Posted by Shark88 View Post
I changed the plugs and the old ones didn't really seem bad. Didn't really notice a difference. Also what is a good vendor for plug wires. I almost bought a set last year at a dealer but they were listed for an 08 & up. Didn't know if there was a difference so I didn't get them.
Victory Kingpin Ignition & Accsy's - Victory Kingpin - Shop Parts and Accessories - Your #1 Source for US Made, Custom Victory & Indian Motorcycle Parts

'15 Gloss Titanium XC.
WOLO Low Tone Disc Horn
Tri-Oval Slip Ons
Black LED Headlight
Kingpin Metal Fork Guards
Ricz Lay Down Plate
Lloydz Timing Wheel & Throttle Ring
Shinhopples Grip Covers
12" Long Ride Shield
Bad Ace Billet Fork Mounted Air Deflector
Ness Signals; Amber front, Red rear

http://www.pure-gas.org/

"I leave the BUG CARNAGE on my screen , it adds character!"-LILMAGS500
doobliss is offline  
post #7 of 7 (permalink) Old 09-27-2018, 09:37 PM
Senior Member
 
rojo154's Avatar
 
Join Date: Aug 2010
Location: Southington, Conn.
Posts: 106
Garage
Default

Quote:
Originally Posted by Shark88 View Post
When I got my Kingpin last year it really seamed to run a little rough at idle and it seemed that the only way it would idle properly was if I kept the fuel enriched on. Well that all changed today. With the help of a YouTube video I watched from the Vic Shop I pulled the tank and cleaned out the throttle body, buttoned it back up and started her up.
Also, when I had the air box cover off I also checked my fuel enricher adjustment and found it only opened ever so slightly, there was so much slack in the cable I can't believe it moved and opened at all. Before when I started the bike it idled only around 800 rpm and that was with the enricher turned up. Now after I started her it ran about 1400 rpm with the enricher off. I adjusted the Idle to 1000 rpm and took her around the block and it feels smoother and more responsive, I can't wait to open it up on the highway now.
I was running late today getting it back together and I didn't have time to pull the plugs and check them yet, so that's next. I have just over 14,000 on the bike now so I'm not thinking they need changed, but if it wasn't running right all that time I'm thinking they might, we'll see. Ready for the summer now!
Sounds like the tb's were never cleaned, must have been gunked up pretty good. If it idle was at 1400 after cleaning the previous owner must have kept adjusting the idle up as needed. You'll know when they need cleaning as the idle speed drops.

2011 XC
rpw exhaust
wiseco fuel controller
Sold

2004 Kingpin
Victory performance exhaust
customized air box / K+N filter
LLoydz fuel controller
custom oil lines
custom led lighting
custom led third brake lights
Sold ..( my baby, still have some sellers remorse)


2011 Kingpin
custom paint
Ness fly bars
xbow exhaust
S&S air intake
chrome floorboards
cruise control
rojo154 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Victory Forums - Victory Motorcycle Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome