2004 fuel pump - Victory Forums - Victory Motorcycle Forum
 4Likes
  • 1 Post By Pietperson
  • 3 Post By Pietperson
 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 5 (permalink) Old 09-16-2019, 12:02 PM Thread Starter
Junior Member
 
Join Date: Nov 2018
Posts: 19
Default 2004 fuel pump

My mechanic tells me my fuel pump is not putting out enough pressure. Also says the 2004 kingpin pump is not available from the dealer any more. rylan at the vic shop can rebuild it, but was wondering if anyone knows who made them originally and if that pump was a standard part on another vehicle? TI automotive might have been the manufacturer but can't get the part# till shop opens tomorrow. Just wondering if anyone here has replaced their pump and from where?
Pietperson is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 09-16-2019, 12:44 PM
Lifetime Premium
 
BBob's Avatar
 
Join Date: Aug 2010
Location: NW AZ
Posts: 12,924
Garage
Default

A lot of people are using the Quantum fuel pumps as a replacement with good results. Of course there will always be those who don't get the results they expect and of course they will be very vocal on the Internet. All products made by man has a success/fail rate.

https://www.highflowfuel.com/p-2965-home.html
BBob is offline  
post #3 of 5 (permalink) Old 09-16-2019, 05:52 PM Thread Starter
Junior Member
 
Join Date: Nov 2018
Posts: 19
Default

I'm gonna suggest that to my mechanic tomorrow and get the model number. Pretty sure walbro made the pump.
BBob likes this.
Pietperson is offline  
Sponsored Links
Advertisement
 
post #4 of 5 (permalink) Old 10-05-2019, 04:30 PM Thread Starter
Junior Member
 
Join Date: Nov 2018
Posts: 19
Default

Got my kingpin back yesterday, runs great again. Problem I was having was around town, it would not run at a steady rpm without surging, coughing, and jerking. they replaced the intake gasket, showed me where it wasn't seated properly and said it sucked air making it run lean and low pressure on fuel pump, He talked to rylan and replaced the pump with a walbro pump from quantum. Gave me the old one, but since I am not the original owner, I am not 100% certain it was the original pump. Anyway he replaced it and it runs fine.
BBob, CanuckRob and BlackhawkFan like this.
Pietperson is offline  
post #5 of 5 (permalink) Old 10-05-2019, 04:34 PM
Lifetime Premium
 
BBob's Avatar
 
Join Date: Aug 2010
Location: NW AZ
Posts: 12,924
Garage
BBob is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Victory Forums - Victory Motorcycle Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome