turn signal indicator? - Victory Forums - Victory Motorcycle Forum
 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 3 (permalink) Old 05-20-2009, 09:35 PM Thread Starter
New Member
 
Join Date: May 2009
Posts: 4
Default turn signal indicator?

anyone know why the turn signal indicator bulb would not illuminate yet the blinkers still work fine?...first thing i did was change the bulb but still nothing. 2005 vegas any help would be appreciated
fixius03 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 05-22-2009, 07:54 PM
Junior Member
 
dogzilla07's Avatar
 
Join Date: May 2009
Location: western Pa
Posts: 29
Smile

Try checking the connections in the headlight assembly. I recently installed the digital speedo and had the same problem you have. After checking everything again I found a loose connection. Hope this helps!
dogzilla07 is offline  
post #3 of 3 (permalink) Old 05-26-2009, 07:37 PM Thread Starter
New Member
 
Join Date: May 2009
Posts: 4
Default

i took it all apart no loose connections. i pulled the bulb and put a multimeter on it and its got power so the socket has to be bad or bad connection. i used a bulb from another indicator which i knew worked so it cant be the bulb.
fixius03 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Victory Forums - Victory Motorcycle Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome