Victory Motorcycle Forum banner

1 - 8 of 8 Posts

·
Premium Member
Joined
·
6 Posts
Discussion Starter #1
I have just returned from deployment and my bike won't start. i have replaced all the obvious and troubleshot in accordance with the tech manual. I now have the bike at the dealer and they said it was the ECM and now they say that it is the wiring harness. I have not had a single issue with my bike since I bought it new and now this.

The bike will turn over but won't fire and then it fires out the exhaust. I checked the spark and it has a weird spark to it where it will fire on one cylinder and then the other and then it will stop firing and then just fire erratically on either cylinder.

Has anyone heard of these issues or is this just my bike. I need help because the dealer is not very confident and they just keep telling me that it is one thing then another and the bill just keeps getting bigger. Please help.
 

·
Administrator
Joined
·
5,978 Posts
I have just returned from deployment and my bike won't start. i have replaced all the obvious and troubleshot in accordance with the tech manual. I now have the bike at the dealer and they said it was the ECM and now they say that it is the wiring harness. I have not had a single issue with my bike since I bought it new and now this.

The bike will turn over but won't fire and then it fires out the exhaust. I checked the spark and it has a weird spark to it where it will fire on one cylinder and then the other and then it will stop firing and then just fire erratically on either cylinder.

Has anyone heard of these issues or is this just my bike. I need help because the dealer is not very confident and they just keep telling me that it is one thing then another and the bill just keeps getting bigger. Please help.
How long was the bike sitting? Was it stored with fuel in it? Were there any fuel additives in the fuel while it was stored? Is the bike all stock?
 

·
Premium Member
Joined
·
6 Posts
Discussion Starter #3
My wife was starting every week and my brother in law took it for a ride 3 weeks before i got home and it ran fine when he rode it and then after that i started having the problems. i have drained all the fuel and added some lucas cleaner to the new fuel and am still having the same issues.
 

·
Administrator
Joined
·
5,978 Posts
My wife was starting every week and my brother in law took it for a ride 3 weeks before i got home and it ran fine when he rode it and then after that i started having the problems. i have drained all the fuel and added some lucas cleaner to the new fuel and am still having the same issues.
By the way, starting the bike and letting it idle without riding it, is not a good practice. All you really do is transform the bike into a moisture magnet. Next time you put the bike in storage, follow winterizing steps.

How tight are the battery connections? Please check them before you answer this. ;)
 

·
Premium Member
Joined
·
6 Posts
Discussion Starter #6
Kevinx,
i just left the dealership. they said that it was the wiring harness. they replaced the ECU and now they say that it is the wiring harness because they don't get spark and then if he moves it they will get spark. I nothing looks cut or chewed, i just have a hard time believing that it ran fine and then 2 weeks later it doesn't run. I just want to make sure that it is the harness before i spend the money on it. to answer your other questions, yes they have hooked it to the computer and it is not giving any fault codes or errors that is why they think it is the harness.

Have you ever heard of the harness' going bad on the Victory's?

Thanks for your response.
 

·
Registered
Joined
·
147 Posts
What scares me is they have changed their story as to the fault, which suggests they are guessing. I hope they aren't charging you for their self training.

Could it be a connector problem?
 

·
Premium Member
Joined
·
6 Posts
Discussion Starter #8
They are trying to charge me, the mechanic said that he was going to get in contact with victory directly to see if they would recommend anything else before replacing the harness, I am under the same thinking that you are that it is just a loose connection. I am not sold on the bad wiring harness.
 
1 - 8 of 8 Posts
Top