Victory Motorcycle Forum banner
1 - 20 of 28 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter · #1 ·
I took the bike out lastnight and everything was fine started her this morning and took off for work I pulled in only 8 miles later and the engine was knocking so bad it was unbelievable I just put plugs and a fresh oil change any ideas?
 

·
The Diamond
Joined
·
4,001 Posts
Are your plugs correctly gapped? Did you use the correct oil and weight? Are you using Premium gas? Did you check your oil level?

All of these can cause your problems.
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #3 ·
Yep everything is perfect gap at 032 oil is 10w 40 and yes premium gas always the bike has only 7000 miles on it what a shame if it has internal problems never beat on it just dont understand
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #8 ·
Ok I think I got it narrowed down the to the torque compensater anybody know is there a gasket I need to replace when I pull the primary cover off? and any tips for this procedure?
 

·
Registered
Joined
·
48 Posts
20/40 wight oil is recommended.Maybe 10/40 is too light?
Is the oil plug still there?
When the bike is at operating temperature the oil is the same viscosity. the first number representst he viscosity at room temperatures.

Did you adjust the belt drive recently. I would check the belt tension if it is too tight it could be jumping a tooth and it will create a funny clunking noise.

Good luck.

Brad
 

·
Registered
Joined
·
243 Posts
Did you adjust the belt drive recently. I would check the belt tension if it is too tight it could be jumping a tooth and it will create a funny clunking noise.

BradT ..... don't you mean if its too loose, ?


steve
 

·
Registered
Joined
·
48 Posts
BradT ..... don't you mean if its too loose, ?
No I meant too tight, but I said it wrong earlier. Jumping a tooth is normally too loose, worn belt or gears.

Last year on a road trip to PA a friend on a 900 Vulcan had the belt too tight and it started a noise. The noise was like a snapping sound from the front pulley.
The noise was there driving, rolling it forward or reverse.
Funny thing was that it started about 500 miles after the service and the temp rose to mid 90's.
Brought it to a dealer he lossened the belt and noise went away.

Only a suggestion, I always try to remember, try the simple things first.

Brad
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #15 ·
Checked everything pulled the primary cover and it looks absolutely perfect checked all nuts and bolts and they are tight put it back together and still clunking like a harley wtf could it be only 6800 miles on the bike Please help
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #19 ·
Knocking

So I brought my bike in and it was the bolts on the flywheel that was making the bad knocking noise Unbelievable only 6000 miles on it and they wouldnt cover it at all and also the dealer where I brought from was running a 92 cube program in the computer so it cost 741.00 dollars to have them fix that and the right download and it get better I just had in dyno at the local harley shop and its all over the place the air fuel mixture lean rich lean can anybody tune these I am so disgusted with polaris I parked it and am riding harley for now and does anybody know what the torque and horsepower should be on it?
 

·
The Diamond
Joined
·
4,001 Posts
Is your bike under warranty? Did you buy it used? If the bike is under warranty it should be covered. If you bought it used with no warranty then buyer beware.

Sounds like your dealer is lazy or just crappy. The biggest con of Victory is the dealer network.

That being said, get your bike to a good dealer and get the correct download and have the TPS reset.

Where are you located? Maybe Kevin or someone can recommend a better tech.
 
1 - 20 of 28 Posts
Top