Victory Motorcycle Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Hey all, I’m really hoping I can get some help with this one! I have a 2008 Vegas and about 6 weeks ago it just wouldn’t start.
I was told it was the the fuel pump so I have replaced that, then tried it and still no go. I had someone take a look and they said I had no fuel pressure. The fuel pressure regulator was bolted down tight but it was loose where it was seated. I have replaced that now with a brand new one that is nice and tight but still no fuel pressure.
Any thoughts? Heeeeeeeelp! It’s using season!
Thanks
 

·
Registered
Joined
·
7 Posts
Discussion Starter #3
It’s fuel infected and everything is on. I do hear the fuel pump going strong, and have checked the relay as well.
 

·
Premium Member
Joined
·
13,321 Posts
Have you downloaded the service manual and looked at the troubleshooting section for the fuel system and fuel pump? I don't think I can help you from my keyboard. You will need to check the fuel pressure yourself using the methods described unless someone else thinks they can help in another way.

If you can hear the fuel pump spin up but are not registering fuel pressure then it's possible the pressure regulator at the pump is bad or something wasn't set up correctly or some connection isn't snapped in correctly but without doing the hands on checks...

The service manuals are at the link in my sig line below. Page 108 is where the fuel system troubleshooting starts.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #5
Ok I will absolutely check and report back. I have the fuel line connected and dribbling into a Jerry can and when I turn it over it doesn’t seem to be spraying super hard. Mind you, I don’t know how much pressure 40psi would look like
 

·
Premium Member
Joined
·
13,321 Posts
Ok I will absolutely check and report back. I have the fuel line connected and dribbling into a Jerry can and when I turn it over it doesn’t seem to be spraying super hard. Mind you, I don’t know how much pressure 40psi would look like
It won't work like that. You need a pressure gauge that goes on the line on the right side behind the Cheese cover. Should be 49 psi if memory serves.

https://amazon.com/s?k=fuel+pressure+test+kit&crid=3TLAWWG3SO3TK&sprefix=fuel+pre,aps,229&ref=nb_sb_ss_i_3_8
 

·
Registered
Joined
·
7 Posts
Discussion Starter #8
ITS ALIVE!!!!!!!!!!!!!! :ride:

The problem ended up being....where the fuel pump goes into the assembly. There is a small hose that connects the fuel pump to the assembly that it sits in and inside there was a split hose. About 1/2 inch long.
Replaced it with a new piece of fuel hose and it fired right up!!!

BBob, thanks for your info and replying!!! cheers
 
1 - 9 of 9 Posts
Top