Victory Motorcycle Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter #1
My vegas 8 ball has a slight mis-fire only in 2nd gear and between 2600-3000 rpms. It only mis-fires when im accelerating rapidly. The bike is completely stock except the dealer cut out my baffles before i purchased it. Not sure whats causing it. Im takin it to the dealer tommorrow.
 

·
Registered
Joined
·
24 Posts
Discussion Starter #3
Cutting out the baffles effectively de-tuned the engine... the already lean for EPA engine...
I took my bike to the dealer today for an oil change and had them switch out my exhaust pipes with originals that still had the baffles. Same problem:mad: wtf?! Any other suggestions? Spark plugs? I dont know
 

·
Registered
Joined
·
24 Posts
Discussion Starter #5
Well i had the dealer put the stock exhaust pipes with the baffles and still got the hesitation in 2nd gear. The owner of the dealership rode the bike for the 4th time and finally it mis fired when he rode it. Im takin her back tomorrow so they can find out whats goin on.
 

·
Registered
Joined
·
24 Posts
Discussion Starter #6
So I dropped my bike off on 7/10 at the dealership I purchased the bike from. They told me that they would start working on it in a couple days. I called about a week later and the owner of the dealership answered the phone and told me that thay had just drained the fluids and were getting ready to work on the bike. They weren't really sure what the problem was but they were looking into it. About a week later I stopped by to check the progress of my bike. The owners and the mechanic were just sitting around bullshitin. The mechanic told me that he had not had a chance to even start to work on the bike yet. Funny..the owner told me a week earlier that they had just started by draining the fluids. They told me that they will call me in a couple days and tell me whats going on. Fast forward to today, 22 days after dropping off the bike. No phone call. I stopped by the dealership. Like always all the employees were just sitting around (including the mechanic). Anyway, after wandering around for about 5 minutes, the mechanic called me over to him. He told me that he STILL hadn't had a chance to even start working on my bike yet. :mad:. Now to be fair the entire dealership just moved into a new location. They are not completely moved in yet. But if they had told me that they wouldnt be able to even start on the bike for a few weeks, I probably would not be so angry. They suggested that I take the bike so I can ride until they were ready in a week or so. Im always too nice but Im really pissed at this place. So far I havent expressed my anger at them but Im reaching my boiling point. I know the bike is still under warranty so I wont have to pay for anything but c'mon! Thanks for listening.
 

·
Registered
Joined
·
1,331 Posts
Why is your bike still there. After 1 week of that garbage I would have been long gone. What fluids did they drain???replace the fluids and leave
 

·
Registered
Joined
·
24 Posts
Discussion Starter #8
Why is your bike still there. After 1 week of that garbage I would have been long gone. What fluids did they drain???replace the fluids and leave
The owner told me they started on my bike by emptying the fluids. (step 1). But the mechanic tells me they haven't even started on the bike. (Obviously the owner was lying to me). The next closest dealership to me is an hour and a half away. I did pick it up today so I could ride with some friends coming to visit me this weekend because the dealer said they wont be able to start working on my bike for another week. They told me to drop it off in a week or so. That'll give them time to get completely moved in to their new building.
This is a small dealership. They are a used car dealer slash Victory/Polaris dealer. Looks like they make more money off their used cars. There's 2 owners and 1 mechanic that seem to work there. The thing that really fries my ass the most, is that the mechanic seems to care more than the owner.
 

·
Registered
Joined
·
223 Posts
ou should of asked the owner how you look for a mis fire by removing the fluids. That should of been your first clue that you were being bullshited. I do know that warranty work can get pushed back because the factory dosen't pay full price.
 

·
Registered
Joined
·
1,499 Posts
Not plugs, but the plug wires, and most likely on the coil end
Did you miss this note from KevinX or try it and no results posted??? This is a 40 dollar possible solution to replace a set of wires. Im sure if you want to keep pressing on a dealer you can but I'm thinking if KevinX tossed you something to check he prob had a good reason to point this out.

http://www.noemtz.com/ignition.htm

Im with AZDave on the dealer and would be looking elsewhere... You should be able to get some good troubleshooting right here on the forums if you post followups... Alot of good knowledge around here.


Just a thought. Keep us posted...
 

·
Registered
Joined
·
24 Posts
Discussion Starter #11
Did you miss this note from KevinX or try it and no results posted??? This is a 40 dollar possible solution to replace a set of wires. Im sure if you want to keep pressing on a dealer you can but I'm thinking if KevinX tossed you something to check he prob had a good reason to point this out.

http://www.noemtz.com/ignition.htm

Im with AZDave on the dealer and would be looking elsewhere... You should be able to get some good troubleshooting right here on the forums if you post followups... Alot of good knowledge around here.


Just a thought. Keep us posted...
Being that the bike is still under warranty, i dont want to start buying a bunch of parts to try and fix the problem. Ill make the dealership figure it out and it wont cost me anything. Just wish theyd stop dickin me around
 
1 - 11 of 11 Posts
Top