Victory Motorcycle Forum banner

1 - 20 of 20 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
I need help resolving this issue I am having with my 2013 Victory High Ball. I am in the US Navy and have been deployed back to back at sea for months and I forgot to disconnect my battery. When I came back from deployment I replaced the battery but the speedometer, odometer, and sensors are not working. Additionally, the bike would not start and tail and signal lights are not working. The only thing that is working is the headlight and horn. I checked the fuses and the connection on top of the tranny with no change in status. No indications on the gauge when starting the bike. The tank has gas. All assistance would be greatly appreciated.
 

·
Registered
Joined
·
130 Posts
A quick glance tells me the headlight and horn aren't in the ignition switch circuit. Check out the ignition switch contacts. Make sure they're not corroded or loose. Where was your bike stored? Salt air is very corrosive (ex-Navy biker).
 

·
Registered
2012 Victory Cross Country Tour, Indianapolis
Joined
·
1,757 Posts
So are you saying the bike runs but none of the electrical stuff is coming on?
 

·
Registered
Joined
·
10 Posts
Discussion Starter #4
A quick glance tells me the headlight and horn aren't in the ignition switch circuit. Check out the ignition switch contacts. Make sure they're not corroded or loose. Where was your bike stored? Salt air is very corrosive (ex-Navy biker).
My bike was park outside with a cover but when I got back from deployment I'm guessing the wind blew it away. I was stationed in Yokosuka, Japan and yes it gets really humid. I check out the ignition switch circuit. By the way, I forgot to mention the battery is not the same size but has the same specs.
 

·
Registered
Joined
·
130 Posts
I don't think it's the battery. Cold cranking amps (current) is what's needed to crank the engine. Most batteries should be able to power up the indicators.
 

·
Registered
Joined
·
130 Posts
Haven't had my coffee yet....

You might try using another battery just in case you misread the battery specs. This is a 12 Volt system, so you could jumper a car battery....
 

·
Registered
Joined
·
10 Posts
Discussion Starter #7
So are you saying the bike runs but none of the electrical stuff is coming on?
The bike does not run. The only thing that is working is the head lights when I turn on the ignition. I don't see speedometer getting any power. When I turn on the switch control to start it just makes a continuous buzzing noise but when I push the button to start it nothing happens. No display or light on the speedometer, no power on the tail lights or the turn signals. The only thing that is working is the head light, high beam, and the horn.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #8
Haven't had my coffee yet....

You might try using another battery just in case you misread the battery specs. This is a 12 Volt system, so you could jumper a car battery....
Yeah, I figure. I got a battery in order but for the mean time I will continue to troubleshoot this issue. I'll double check the fuses with multimeter just to make sure.
 

·
Registered
Joined
·
130 Posts
The bike does not run. The only thing that is working is the head lights when I turn on the ignition. I don't see speedometer getting any power. When I turn on the switch control to start it just makes a continuous buzzing noise but when I push the button to start it nothing happens. No display or light on the speedometer, no power on the tail lights or the turn signals. The only thing that is working is the head light, high beam, and the horn.
A discharged battery can power the headlight and cause relays to buzz (relay closes, but not enough current to keep it closed against the spring tension, so it oscillates, buzzes). Lights, horns are very low load resistance. Basically a short from power to ground with an inline resistor.

I'm beginning to think your issue is centered around the battery itself.

A somewhat personal question -- are you a bubblehead?
 

·
Registered
Joined
·
10 Posts
Discussion Starter #10
A discharged battery can power the headlight and cause relays to buzz (relay closes, but not enough current to keep it closed against the spring tension, so it oscillates, buzzes). Lights, horns are very low load resistance. Basically a short from power to ground with an inline resistor.

I'm beginning to think your issue is centered around the battery itself.

A somewhat personal question -- are you a bubblehead?
I'm kind of new at this so I am a bubblehead. You still haven't got your coffee yet? So are you suggesting I should wait for the new battery to come in? Where is the inline resistor?
 

·
Registered
Joined
·
10 Posts
Discussion Starter #11
I'm kind of new at this so I am a bubblehead. You still haven't got your coffee yet? So are you suggesting I should wait for the new battery to come in? Where is the inline resistor?
I'm going to try to put the old battery and jump it.
 

·
Registered
Joined
·
130 Posts
Your answer tells me you're not on a sub (bubblehead). At least that's what submariners were called back in my day. Wasn't meant to be derogatory.

If it were my bike, I'd jumper my Jeep battery and see if the problem persisted. Batteries sit on the shelf for years sometimes before they're sold. I always trickle charge new batteries before I install them. Even then, an old (new) battery may not hold a charge. Using a proven battery helps determine if the bike's battery is the problem.

The inline resistance is part of the component itself. The light element, the horn coil, etc. This prevents a direct short across the power supply (battery). I use the term "resistor, resistance" because this is a DC circuit.
 

·
Registered
2012 Victory Cross Country Tour, Indianapolis
Joined
·
1,757 Posts
Just don't connect a motorcycle to a running vehicle.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #15
Your answer tells me you're not on a sub (bubblehead). At least that's what submariners were called back in my day. Wasn't meant to be derogatory.

If it were my bike, I'd jumper my Jeep battery and see if the problem persisted. Batteries sit on the shelf for years sometimes before they're sold. I always trickle charge new batteries before I install them. Even then, an old (new) battery may not hold a charge. Using a proven battery helps determine if the bike's battery is the problem.

The inline resistance is part of the component itself. The light element, the horn coil, etc. This prevents a direct short across the power supply (battery). I use the term "resistor, resistance" because this is a DC circuit.
It's all good. I thought since you are a Navy veteran that's how we all talk. LOL. I bet you are a Chief the way you describe your coffee. I will definitely attempt all this suggestions.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #17
My Motorcycle is now working. I like to thank you all for the assistance on getting my Victory alive again. Now I just need to register and start riding as much as I can. Again, thank you for your rapid assistance on this issue. Belated Happy Thanksgiving
 

·
Registered
2012 Victory Cross Country Tour, Indianapolis
Joined
·
1,757 Posts
My Motorcycle is now working. I like to thank you all for the assistance on getting my Victory alive again. Now I just need to register and start riding as much as I can. Again, thank you for your rapid assistance on this issue. Belated Happy Thanksgiving
What was the problem? Battery?
 
1 - 20 of 20 Posts
Top