Victory Motorcycle Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
40 Posts
Discussion Starter #1 (Edited)
I just noticed last night that the taillight does not come on when I start the bike ( 03 V92TC) . It works fine when I apply either brake. And the blinkers work fine as well. In fact all other lights are working fine as well. It's just the taillight. I didn't ride last night since cars and others wouldn't see me from behind until I slowed down or stopped.

Any ideas or fixes? Is it the bulb? Is it wiring? Both? Neither?
 

·
Registered
Joined
·
1,510 Posts
What bike? What kind of taillight/turn signal assembly? I had a similar problem on the integrated tail light/brake light assembly on my XCT. The lights would be on brightly some of the time, on but very weak other times, and not work at all at still other times. I had to replace the entire sealed assembly.

G'day,

Vinish
 

·
Registered
Joined
·
40 Posts
Discussion Starter #4 (Edited)
What bike? What kind of taillight/turn signal assembly? I had a similar problem on the integrated tail light/brake light assembly on my XCT. The lights would be on brightly some of the time, on but very weak other times, and not work at all at still other times. I had to replace the entire sealed assembly.

G'day,

Vinish

Its an 03 V92TC. Tail light sits alone on fender. Blinkers are built into Bags.
 

·
Moderator
Joined
·
13,002 Posts
the tail light bulb is dual filament. One is for brake and the other one is for taillight. So start with bulb first.
Auto store will have bulb.
 

·
Registered
Joined
·
40 Posts
Discussion Starter #7
the tail light bulb is dual filament. One is for brake and the other one is for taillight. So start with bulb first.
Auto store will have bulb.


That was the fix. It's a Bulb, Dual Filament 4010222 ..... popped a new one in and all good again... I'm not scared of the sun setting anymore....
 
1 - 7 of 7 Posts
Top