Victory Motorcycle Forum banner

1 - 20 of 202 Posts

·
Registered
Joined
·
31 Posts
Discussion Starter #1 (Edited)
This is 1 block of riding at 20 mph after installing a witchdoctor open belt cover to cure my belt rub. To much of my dismay after riding I smelt burning rubber to look back and see this.



Updated pics. I reinstalled cover to show problem


Allen wrench showing where contact is made






 

·
Premium Member
Joined
·
4,178 Posts
Your belt is still rubbing inside the open cover, its not WDs fault, im guessing you lowered your bike? What bike? When you lower some of the year bikes the belt hits the bolt boss, so by replacing the cover you fixed nothing. The WD cover may have a heavier duty boss thats thicker so thats why it will rub more, did you tell him you were having rubbing issues before you bought the cover?

Sent from Motorcycle.com App
 

·
Premium Member
Joined
·
1,872 Posts
As others have asked, have you called Jon at Witchdoctors and talked to him about this prior to posting this thread? They're one of the best
vendors Victory owners have and they always do whatever they can to resolve issues. As has also been asked, is your bike lowered and did Witchdoctors know this at the time you ordered your item.
 

·
Registered
Joined
·
73 Posts
Who installed it? Did they or you check for clearance issues before riding off into the sunset? WD is a very standup
guy and takes pride in his business and his customers....If there had a been and issue WD would have made it right, if I was him now I wouldn't!
 

·
Premium Member
Joined
·
9,684 Posts
If clearance was an issue to begin with , was it checked after the new cover was installed , if not , why ?
 

·
Premium Member
Joined
·
9,684 Posts
Can you post more pictures , from different angles of the cover ? Maybe your belt was smoked before you put the new cover on and you just didn't notice it :rolleyes:
 

·
Registered
Joined
·
1,845 Posts
Soooo you WD blowhards come to defense of WD when obviously the stock cover didn't rub. How many of you guys have checked the clearance of the belt to cover? How many of you guys jump on here to report a problem as soon as you have an issue? Thanks for the heads up on another issue from one of our victory vendors. Just to mention when you adjust the belt you don't adjust it for clearance, you adjust it for tension....

Sent from Motorcycle.com Free App
 

·
Premium Member
Joined
·
4,178 Posts
Soooo you WD blowhards come to defense of WD when obviously the stock cover didn't rub. How many of you guys have checked the clearance of the belt to cover? How many of you guys jump on here to report a problem as soon as you have an issue? Thanks for the heads up on another issue from one of our victory vendors. Just to mention when you adjust the belt you don't adjust it for clearance, you adjust it for tension....

Sent from Motorcycle.com Free App
WTF! he said in his post his belt was rubbing so he put on the WD cover to fix it, He obviously doesnt know why it was rubbing in the first place or he would have saved his money and ground down the bolt boss to solve his issue.

Sent from Motorcycle.com App
 

·
Super Moderator
Joined
·
5,063 Posts
This is 1 block of riding at 20 mph after installing a witchdoctor open belt cover to cure my belt rub. To much of my dismay after riding I smelt burning rubber to look back and see this.
Soooo you WD blowhards come to defense of WD when obviously the stock cover didn't rub. How many of you guys have checked the clearance of the belt to cover? How many of you guys jump on here to report a problem as soon as you have an issue? Thanks for the heads up on another issue from one of our victory vendors. Just to mention when you adjust the belt you don't adjust it for clearance, you adjust it for tension....

Sent from Motorcycle.com Free App

Seems it did rub.
 

·
Premium Member
Joined
·
9,684 Posts
D , please define Blowhard ! :ltr:
 

·
Registered
Joined
·
158 Posts
From looking at the first post and the picture i'm with LILMAGS500.

I think its the turnedout bassini pipes fault. LOL:ltr:

I'm just kidding. I had to thought. Until the poster gives us more info theres not alot to fix here. thumb up

BLOW HARD- when a woman can push a golfball through a garden hose with only her hot air. LOL
 

·
Premium Member
Joined
·
9,684 Posts
I just went and looked at WD's open belt covers , I don't see how , where his belt is worn could have possibly happened with one of these covers , WD or otherwise , I know Conquest customs offer these too. Something is awry with the installation , IMO , until further evidence is provided to the contrary . It seems the OP has disappeared for the time being .
 

·
Administrator
Joined
·
5,988 Posts
...IMO , until further evidence is provided to the contrary . It seems the OP has disappeared for the time being .
Seems that way. Probably put his foot in his mouth and hid under a rock. :ltr:
 

·
Premium Member
Joined
·
9,684 Posts
Seems that way. Probably put his foot in his mouth and hid under a rock. :ltr:
My thoughts exactly , probably left an Allen wrench between his belt guard and belt . OOOOpS ?:ltr:
 

·
Moderator
Joined
·
13,235 Posts
This is 1 block of riding at 20 mph after installing a witchdoctor open belt cover to cure my belt rub. To much of my dismay after riding I smelt burning rubber to look back and see this.

Guessing you didn't look to see if you installed it correct.
Why are you here bad mouthing Witchdoctor when you should be talking to them to get it straightened out. I'm sure Jon did his home work before putting it on the market.
 
1 - 20 of 202 Posts
Top