Victory Motorcycle Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
365 Posts
Discussion Starter #1
was out on a ride with 5 others and was in front,coming through mid wales,I rounded a blind sharp narrow bend at the start of a steep climb when the bike suddenly stopped. Iwas stranded in middle of road holding bike on brake the other riders and a mercedes estate car just managed to go around me,it was very close. Switched ignition on and off afew times and had to find neutral on a steep hill to start the bike again. Pulled over at a layby and found battery terminals had worked loose,tightened them up and the bike ran home ok. I was quite shaken by this and now think the "starts only in neutral" idea not so good,the time it took to get the bike out of a hazardous situation was critical,but I will check these terminals every month from now.
 

·
Registered
Joined
·
567 Posts
was out on a ride with 5 others and was in front,coming through mid wales,I rounded a blind sharp narrow bend at the start of a steep climb when the bike suddenly stopped. Iwas stranded in middle of road holding bike on brake the other riders and a mercedes estate car just managed to go around me,it was very close. Switched ignition on and off afew times and had to find neutral on a steep hill to start the bike again. Pulled over at a layby and found battery terminals had worked loose,tightened them up and the bike ran home ok. I was quite shaken by this and now think the "starts only in neutral" idea not so good,the time it took to get the bike out of a hazardous situation was critical,but I will check these terminals every month from now.
It is called "preventive maintenance" ...a drop or two of locktight wouldn't hurt either (blue formula)
 

·
Registered
Joined
·
307 Posts
dunno if you have this or not but on my 2007 hammer all of a sudden i couldnt start it in gear turns out there is a plug connector right at the clutch lever that wasnt connected all the way i pushed it in till i heard a click then i could start the bike in gear.Might want to have a look
 

·
Registered
Joined
·
567 Posts
dunno if you have this or not but on my 2007 hammer all of a sudden i couldnt start it in gear turns out there is a plug connector right at the clutch lever that wasnt connected all the way i pushed it in till i heard a click then i could start the bike in gear.Might want to have a look
Read the post Bro...He stated his battery terminal connector came loose....:crzy:
 
1 - 7 of 7 Posts
Top