Victory Motorcycle Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
216 Posts
Discussion Starter #1
I installed new plugs earlier this week and noticed the old ones appear black. Not wet but carbon fouled perhaps.
I have the Stage One flash, D&D mufflers, Vic Hi performance air filter and Loyd's adjustable timing wheel set at +4.
O2 senors unplugged.

So with the plugs looking like they do AND the occasional popping I get, I'm thinking about re-hooking up the O2s.
Any thoughts?
 

·
Premium Member
Joined
·
4,178 Posts
try it and see what happens, did you go back with the ngks? i dont have any luck with them personally, i run champs and have better luck. RA8GHC is the cross
 

·
Premium Member
Joined
·
6,192 Posts
I keep on buying and replacing to stock plugs ....

So you have NO pcv or anything else ? I think the plug colour shpuld be light grey coz of running lean ??

But i am no expert ?
 

·
Registered
Joined
·
216 Posts
Discussion Starter #4
Yes OEM NGKs.
 

·
Moderator
Joined
·
13,177 Posts
with our motors and shitty ECM your plugs will be black.
Keep in mind when plugs would turn brown when there was lead in the gas.
Your not going to see much of a change hooking up 02's.
02's are good for low end and then they shut off when you get to certain RPM
 

·
Premium Member
Joined
·
2,646 Posts
First things first. A plug chart for a water cooled engine does not show a good burn for an air cooled engine. If you showed me a good running car plug....I'd say it was to lean in my bike. If I showed you a good looking air cooled play.....you would think it was way rich in your car.

Soooooooo......a black base cleaning up about half way up the strap is to me about perfect for a Vic.

O2 sensors are active in any steady state throttle application. Once vacuumed levels off they try to set the engine at stokio. Which is great for emissions, but not so much for cooling
 
1 - 7 of 7 Posts
Top