Victory Motorcycle Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
32 Posts
Discussion Starter #1
I have a 2002 V92tc that I purchased this year. It can be started without the clutch depressed and I can take off with the kickstand down. That being said, it means that it will start if in gear and go without me. I thought that ALL bikes at least post 1980 would have safety features to avoid mishaps. Did the previous owners disable these safety features? I've looked in the repair manual and still can't figure it out. Any idea where they could have disconnected this?
 

·
Registered
Joined
·
537 Posts
Don't know about the Vision and X-Bikes, but none of the rest have ever had a kickstand safety on them. If I recall correctly, there is a clutch safety. Look at the underside of your left control pod where the clutch pivots. There should be a little nipple (YES, I said nipple....) sticking out that the clutch lever depresses when released. They have been known to go bad. The good news is MOST of the time a disassembly and thorough spraying with contact cleaner brings them back to life.....
 

·
Registered
Joined
·
682 Posts
Don't know about the Vision and X-Bikes, but none of the rest have ever had a kickstand safety on them. If I recall correctly, there is a clutch safety. Look at the underside of your left control pod where the clutch pivots. There should be a little nipple (YES, I said nipple....) sticking out that the clutch lever depresses when released. They have been known to go bad. The good news is MOST of the time a disassembly and thorough spraying with contact cleaner brings them back to life.....
My clutch safety switch went out and that's what I did, just sprayed the **** out of it with contact cleaner. Works great now
 

·
Registered
Joined
·
32 Posts
Discussion Starter #5
I took out the switch and sprayed it with contact cleaner. It still didn't work. I then pulled it out again and did a continuity test, and the switch turns out ok. It must be down the line somewhere. Any ideas?
 

·
Registered
Joined
·
682 Posts
Did you make sure the plunger on the switch goes in and out properly? Mine was stuck in, so I sprayed it with the contact cleaner then took a small pocket screwdriver and pried the plunger out gently and sprayed more contact cleaner until I was satisfied with the way it was moving
 
1 - 6 of 6 Posts
Top