Victory Motorcycle Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1 (Edited)
I did some searching but didn't seem to find much on the subject. My friction point or club grab seems to have moved to the very end of my clutch lever. I don't believe I'm experiencing any slippage or anything of that nature. I figured this is from the clutch breaking in? I now have 750 miles on my 09.

I'm new to the larger bikes and have mostly been a car gearhead all my life so any advice on basic maintenance is appreciated!

Thanks in advance.

Edit: btw I picked this bike up a few weeks ago when it had 415 miles on it.
 

·
Registered
Joined
·
109 Posts
Have you done the initial service yet (500 mi)? The initial service should include oil/filter change, plus checking/adjusting cables, etc. The clutch is one of the things to be adjusted. IIRC the manual should list specifications on clutch playl to help with adjustment.

HTH,

Rob
 

·
Registered
Joined
·
7 Posts
Discussion Starter #3
Rob, yes, I took it to the dealer for the 500mi service. I noticed the change a few days after the service towards end of a 2 hour ride.
 

·
Registered
Joined
·
177 Posts
Maybe the jam nut is loose, and allowed the adjustment to change. It shouldn't have moved. As far as I know a clutch doesn't have to break in. During the first couple of engage disengage cycles, the friction discs and plates "mesh/wear" together. It begins the cycle of wearing out from there. I can't imagine that it wore down that fast, unless you ride the clutch or something.
 
1 - 5 of 5 Posts
Top