Victory Motorcycle Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
125 Posts
Discussion Starter #1
Anyone else experiencing this? Time for powder coating on the trees! (Or maybe I can now justify the rake kit) I hope this is rare amongst Vics. ImageUploadedByMO Free1374671859.867587.jpg


Sent from Motorcycle.com Free App
 

·
Moderator
Joined
·
13,038 Posts
it looks like you follow a gravel truck. Look the turn signal is doing the same thing.

Where do you ride or park it. Donesn't look like vic fault but yours
 

·
Registered
Joined
·
1,347 Posts
That would suck !!!
8Balls never have that problem.
 

·
Premium Member
Joined
·
103 Posts
it looks like you follow a gravel truck. Look the turn signal is doing the same thing.

Where do you ride or park it. Donesn't look like vic fault but yours
Don't know whos fault but agree with visionjohnny it is on the turn signal and looks like under the head light, almost like something acidic was throw on it or it was sand blasted in a wind storm or something. Those are after market turn signals also, so different chrome applications so I would not blame it on the chrome or Victory either. Maybe just bad luck on how it happened. :(
 

·
Registered
Joined
·
125 Posts
Discussion Starter #6
Turn signal is only 2 months old too. Salty ocean breezes I guess. Can I justify my powder coated rake kit now? Lol


Sent from Motorcycle.com Free App
 

·
Registered
Joined
·
125 Posts
Discussion Starter #7
No other chrome on bike is affected though. Just the trees and turn signals?????


Sent from Motorcycle.com Free App
 
1 - 7 of 7 Posts
Top