Victory Motorcycle Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
84 Posts
i have a 2012 victory cross country with victory hid kits on high and low sometimes at night when using high beams it kicks cruise off when either turning off high beams or turning them on anyone have a idea what problem is
Check with the folks at Victory HID. There is a known electrical problem with "some Cross Country bikes" that cause different problems when high-beam is turned on for the first time. On mine, if I'm in just the right spots, my radio reboots itself. They said the only real solution is to run isolated, relayed power to the high beam.
 

·
Registered
Joined
·
888 Posts
I'll second the first response. For an electrical control or circuit to fail or reset there has been a drop or surge in the power to that piece. For the power to fail either the source is intermittently faulty or another load is drawing power and the source is not adjusting fast enough. That temporary reduction is what the problem is you describe. It's like turning on a hair dryer or iron in some parts of the house; the lights will flicker.

The lights on a motorcycle are a big load and you can expect problems when they share a source voltage with other circuits. Pick up your power from an isolated source. If there is still a problem then the source needs checking.
 

·
Registered
Joined
·
156 Posts
On my XC, and I think they are all this way, with the high beam on the low is still on too. Maybe try switching the ballasts or the whole high beam and low beam assembly around, high to low, low to high?

It would be pretty easy to do.

In any regard, good luck, and please pass back what you find.
 
1 - 4 of 4 Posts
Top