Victory Motorcycle Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
32 Posts
Discussion Starter #1
my engine light comes on and goes out on its own. I have 57,550 miles on it and this is my first problem. I'm hoping it's a loose wire or something, bad sensor? Could someone point me in the right direction?
thanks
 

·
Registered
Joined
·
32 Posts
Discussion Starter #4
I took it for a ride and when the light came on I pulled over and checked the voltage, it was 17.56. So now I'm trying to find one but having trouble,never had to buy anything but tires and oil. I'd rather not go to the dealer for one
 

·
Premium Member
Joined
·
13,159 Posts

·
Registered
Joined
·
32 Posts
Discussion Starter #6
Thanks, I looked at witchdoctors and victory only. I guess I'll cal LLOYDS tomorrow. Last resort will be the dealer
 

·
Registered
Joined
·
567 Posts
Seems like I remember seeing a video or a write-up somewhere that showed where you could use a regulator that was from another brand that was very similar that would work with "slight" modifications/ I will see if I can find it.
 

·
Registered
Joined
·
567 Posts
Ok...found it....on the "other" site, first: Check and see if Paulie has one-
Paulie Tomanicek - Parts Sales
(419) 891-1230 ext 235
(877)-437-1631
[email protected]

Second , if you don't want OEM or cannot find one give this guy a call. Home
 

·
Registered
Joined
·
32 Posts
Discussion Starter #9
Thanks, I got one. Called lloyds they referred to the vic shop, he could get me one but I wanted it now so he gave me the oem part number and I got one at the dealer. I'm surprised at all the help I got from every one, it's amazing.
thanks
 
1 - 9 of 9 Posts
Top