Victory Motorcycle Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
38 Posts
Discussion Starter #1
well my 2010 vegas with 18k miles has been down a good part of the summer. One day upon starting it just quit fouled plugs then let the fouled plugfest begin. so between every change i made i was getting between 10 and 40 miles before starting again. i was running too rich.1 so i pulled the baffle and cleaned the air cleaner NOPE. 2changed coil pack/plug wires NOPE. 3. Cleaned the throttle body NOPE. 4. Engine light finally came on. took it to the shop had a bunch of ( idle air control circuit out of range) codes upon mechanics recomendation i replaced the Low air cut off valve breather solenoid and the TMAP Sensor NOPE!! 5. then found a thread about re setting the TPS ( throttle position sensor). a 10 second deal. Afterwards i heard some kind of sound that i have never heard before? This appears to have fixed it. i have well over 150 miles on it and seams to be running perfect as before. Sure hope this helps someone due to my struggles. I can post the directions for this if anyone is interested
 

·
Registered
Joined
·
1,540 Posts
Absolutely, please post the instructions. I know that I would be interested. This would be applicable to all Victory bikes and not just the steel frame ones, correct?

G'day,

Vinish
 

·
Registered
Joined
·
38 Posts
Discussion Starter #3
all i know is that this worked on my 100 cu "

1. start with key and kill switch off.
2. key to on ( let prime) kill switch on
3. slowly roll throttle from 0% to 100%.
4. Hold throttle wide open for 5 sec.
5. let throttle snap back to 0% as fast as possible
6. turn kill switch off then key off

thats it good luck
 

·
Registered
Joined
·
21 Posts
This does work for all Vics. It worked on my 99 V92C and it worked on my 07 Jackpot
 
1 - 5 of 5 Posts
Top