Victory Motorcycle Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
33 Posts
Discussion Starter · #1 ·
I have a 2005 vegas with 13,000 miles and a stage 1 kit. The bike starts hard and struggles to stay running untill warm then runs slitly better. When i hit the throttle it sputters and backfires. I have already cleaned the airbox, filter and the throttle bodies and installed new plugs.
The plugs look black , black smoke comes out the exhaust, and my eyes water just being near it lol .I believe it to be running rich and plan on buying a fuel controller. Will this solve my problem or do i need to take it to the dealer to get the fuel mapping closer before buying the controller? Thanks in advance for any help
 

·
Premium Member
Joined
·
1,637 Posts
I have a 2005 vegas with 13,000 miles and a stage 1 kit. The bike starts hard and struggles to stay running untill warm then runs slitly better. When i hit the throttle it sputters and backfires. I have already cleaned the airbox, filter and the throttle bodies and installed new plugs.
The plugs look black , black smoke comes out the exhaust, and my eyes water just being near it lol .I believe it to be running rich and plan on buying a fuel controller. Will this solve my problem or do i need to take it to the dealer to get the fuel mapping closer before buying the controller? Thanks in advance for any help
I would think a Lloyds fuel controller will get you closer to where you want to be. I'm sure Kevin can offer some words of Victory Wisdom.....
 

·
Registered
Joined
·
33 Posts
Discussion Starter · #4 ·
I just talked to lloyd he sugested changing the temp sensor that threads into the rear jug.
From what he explained it sends information to the ecu and can cause these problems. I just orded one from the dealer $30
 

·
Premium Member
Joined
·
2,646 Posts
I would check the temp sensor, but it sounds like the TPS adjustment is way out. I would also try doing a throttle point reset first

Key on, switch on, engine off
Slowly rotate the throttle from closed to wide open[slow 5 count]
Hold throttle open for slow 5 count
Let throttle snap shut
Cycle kill switch
Start bike
 

·
Registered
Joined
·
33 Posts
Discussion Starter · #6 ·
Thanks for the advice kevinx ill give that a shot. My guess the my problem is some minor issue and will be sure to inform this board when its solved in case someone else has this issue.
 

·
Registered
Joined
·
33 Posts
Discussion Starter · #7 ·
Just a quick update as promised . I changed the air temperature sensor and the engine temperature sensor. Problem solved. thanks again for the help
 
1 - 7 of 7 Posts
Top