Victory Motorcycle Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
105 Posts
Discussion Starter · #1 ·
Hey folks, on a ride this morning and my gear indicator stopped working. I was shifting at the time it stopped. So what could be wrong? Everything else on that screen is working; time, temperature and total mileage. Neutral does show up. I recently had new tires and brakes in the front and back. Is there anything I can check possibly before I take it to the mechanic? Thanks for any information that you can provide.
 

·
Registered
2012 Victory Cross Country Tour, Indianapolis
Joined
·
2,698 Posts
Clutch switch on handlebar.
When the switch is not being engaged the dash will show all sorts of psycho numbers because it can't tell when you pull clutch.

You should be able to hear the clicking of the switch as you pull and release on the clutch lever.
 

·
Registered
Joined
·
105 Posts
Discussion Starter · #3 ·
I’m not seeing any unusual numbers, just a dashed line where the gear number would normally be. On a search someone also talked about that switch so I took it apart, cleaned it out and reassembled it with no change. Let me add since the gear indicator number has disappeared, my clutch lever at rest is looser than normal. The bike shifts normally without any slippage while under power. Another search said that there is a piece of metal that contacts the clutch lever that can slip out of place and that causes the gear number not to be shown. I don’t know how to check for that and I’m assuming if that happened maybe that’s why my clutch lever feels loose at rest? Any comments on that?
 

·
Registered
2012 Victory Cross Country Tour, Indianapolis
Joined
·
2,698 Posts
There is a tab on the lever that activates the switch if that is what you mean.

I don't see how that would cause issues with the lever pull.

I think if the switch fails in the clutch on/pulled position the bike would always have a '-' on screen as it does when you normally pull clutch in.
If that's the case your bike could start in gear, my uncle did that once, it was only funny afterwards since it didn't fully start and take off without him.

There is probably a test for the switch in the service manual.
 

·
Registered
Joined
·
60 Posts
Hey folks, on a ride this morning and my gear indicator stopped working. I was shifting at the time it stopped. So what could be wrong? Everything else on that screen is working; time, temperature and total mileage. Neutral does show up. I recently had new tires and brakes in the front and back. Is there anything I can check possibly before I take it to the mechanic? Thanks for any information that you can provide.
Adjust your clutch. I recently changed out my handlebars and I run into the same problem. When I took it out for a test ride, I had only the dash line also. While your riding, take your finger and push your clutch lever all the way out and your gear indicator should show up. If that happens, adjust your clutch until you have just a little play at the handle, (there's plenty of videos about how to adjust). I think that should fix it.
 
  • Like
Reactions: IndyVictory

·
Registered
Joined
·
105 Posts
Discussion Starter · #6 ·
Thanks to all that have responded. I brought it to the mechanic and it turned out to be the switch that broke. A new switch has been ordered and will be installed once received.
 
1 - 6 of 6 Posts
Top