Victory Motorcycle Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Grew up in MN with Polaris toys all over the place, started riding Victories after my dad bought a V92C in '99, and bought my own '06 Vegas that's still my daily driver. I'm no stranger to bike maintenance and forums in general (revived and bobbed an old Suzuki v-twin, built a CB750 chopper, etc), but I've honestly never had any issues with my Vegas at all - hence this being my first post ever...

Recently my dad gave me his old V92C; he had a Vegas and then a Vision, so the '99 sat basically untouched for a few years. He didn't want to sell it and thought I could get some use out of it, so last weekend I trailered it down to Kansas City to bring it back to life. Naturally, after sitting for so long it has it's issues. I have my theories, and I'm hoping to sort it all out with your help. Glad to be here.

Cheers,
David
 

·
Registered
Joined
·
2,699 Posts
David welcome to the Victory Forums and congrats on being a long time Vic fan!

Let's get your initial posts out of the way quickly so you can post your problems in the tech section.
 

·
Registered
Joined
·
169 Posts
Welcome to the forum. You stated "down to KC", are you from around St Jo?
 

·
Registered
Joined
·
2 Posts
Discussion Starter #5
Thanks all.

I trailered the bike from Minneapolis down to Kansas City where I currently live. Looking forward to bringing this thing back to life. I think I've concluded that the fuel pump needs replacing or rebuilding, gonna try one more diagnostic on it then hit up the forum for input. Thanks again.

David
 
1 - 6 of 6 Posts
Top