Victory Motorcycle Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
399 Posts
Discussion Starter #1
So I bought a PBR300x2, alpine type S speakers, wiring kit and hawg wired mount off somebody on here.

When looking at the mount and the amp I realized there are only the 2 holes for mounting on the bracket and those align with the holes on the bike. Unfortunately the bolts for that are bigger than the openings on the amp so can't share that, or so it seems.

Should I just drill new holes in the mount for the amp?


Sent from Motorcycle.com Free App
 

·
Premium Member
Joined
·
4,498 Posts
I think the idea is to drill holes for your specific amp... At least the one I purchased from Vtwin Audio is that way.
 

·
Registered
Joined
·
399 Posts
Discussion Starter #3
Ok. I just wasted to make sure I wasn't missing some sort of easy way to get it on there.


Sent from Motorcycle.com Free App
 

·
Registered
Joined
·
66 Posts
I thought there was possibly self tapping screws if not drill it how you would like. The 2 holes are for fairing
 

·
Registered
Joined
·
399 Posts
Discussion Starter #5
The two screws with the mount were for mounting to the bike doesn't seem like it would work for the amp. I didn't see any self tapping.


Sent from Motorcycle.com Free App
 

·
Registered
Joined
·
66 Posts
Maybe in with the amp. Sorry couldn't be of not help. I ended up using witchdoctors amp and mount. It wouldn't hurt to drill holes in the mount to provideore airflow for the amp. Figure if drilling it out already.
 
1 - 6 of 6 Posts
Top