Victory Motorcycle Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
34 Posts
Discussion Starter #1
I installed HID headlight. The issue I have is if I turn the highs on my radio blinks for a little bit. I also shut the bike off with the highbeam on. When I restarted all of my guages went out. Pulled relay out and put it back in and came back on. Lights look great but I cant flip my highbeam on without the radio cutting off. Seems like I need a relay. Anyone.
 

·
Registered
Joined
·
1,533 Posts
which HID kit is it? where did you buy it?
 

·
Registered
Joined
·
4,078 Posts
I installed HID headlight. The issue I have is if I turn the highs on my radio blinks for a little bit. I also shut the bike off with the highbeam on. When I restarted all of my guages went out. Pulled relay out and put it back in and came back on. Lights look great but I cant flip my highbeam on without the radio cutting off. Seems like I need a relay. Anyone.
I had the same happen to me, VictoryHID's recommended placement is too close with a hi and low beam ballast. You need to move the ballasts away from the electronics in the fairing. Stick them to the inner fairing as far away as possible from the radio.
 

·
Premium Member
Joined
·
4,178 Posts
i moved mine to where he suggests in the side if the fairing mount, and pulled the wiring as much away from the radio as i can, works great now, no issues
 

·
Registered
Joined
·
1,533 Posts
You two nailed it, that's exactly what I was getting at when I asked which HID and where he bought it. I know if he got the VictoryHid kit from CC then it's most likely just a simple interference issue. I'll be ordering the low beam before long.
 
1 - 5 of 5 Posts
Top