Victory Motorcycle Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter #1
I have an 07' Vegas Premium, RPW slash pipes, S&S airbox and I just installed the VCF-III a few days ago.

I used the recommended settings given to me by Lloyd 3-1-3-0-6-3.5

The VCF-III has cut down my exhaust popping down 90% and makes the bike run great. But I have noticed that my bike idles high when I pull up to a stop light. When I start my bike up it idles "normal" at (I am guessing) 1K RPM and has that awesome rumble. But if I touch the throttle in anyway (still in neutral) the RPM now stay at 2500+. So when I am driving around and pull up to the stop light the RPM stay high and never go back down to 1K.

Is this normal for the VCF? I know the "green light" is the idling control on the VCF (it is at 3). Should I keep this setting at 3?

Thank you for the help
 

·
Moderator
Joined
·
13,247 Posts
Did you adjust any of the idle crew when you were installing the VFC

I do think your throttle and idle cables are not adjusted correct
 

·
Registered
Joined
·
20 Posts
Discussion Starter #3
I spent a lot time last night taking off the tank and adjusting the throttle cables. The bike will idle just fine when I start it up..but will go higher if touch the throttle. I idled the bike and adjusted the green light on the VCF and I could get it back down to normal if I set it at 1 (instead of 3). But does anyone know if this defeats the purpose of the VCF by making the setting a 1?
 

·
Registered
Joined
·
100 Posts
I would suspect the throttle and high idle cables. Make sure the high idle lever cable has slack and is not binding.
 

·
Registered
Joined
·
427 Posts
Lube up the cables and check for slack. Is the throttle returning to normal position when you let off of it?
 

·
Registered
Joined
·
20 Posts
Discussion Starter #6
I checked all cables and it looks like I have slack. The throttle does go back to normal position when I let it off.

When I start the bike the idle is perfectly fine. When I change the first setting on the VCF (Green light) (after riding it when the idle is high) the idle goes back to normal when I adjust it from the now 3 to a 2, 1.5, or 1.

I will email Danny from Llyods to see if its the VCF or I need to pull the tank and go over all cables.
 

·
Registered
Joined
·
20 Posts
Discussion Starter #7 (Edited)
I contacted Danny at Lloyds and he wanted me to check the black caps on the side of the throttle body to see if they were cracked. So I took off the tank, S&S intake, and saw that the 2 black caps on the right side of the throttle body had small cracks in them (thus letting air out). Just had to wrap them in black tape to fix.

I also disconnected the battery, reconnected battery, started the bike, and changed the "green" setting on the VCF to 2.5 (instead of 3). Everything is now fixed with no high idling issues.

Danny is a genius over at Lloyds.
 

·
Registered
Joined
·
477 Posts
I've emailed with Danny a few times, he's very helpful.
 
1 - 8 of 8 Posts
Top