Victory Motorcycle Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Bought 2001 V92c new in 2002. Been riding sporadically ever since. Bike has just over 8000 miles on it, but ride several years with the Speedo not working so probably closer to 10k on it. Drug it out of the garage and for the first time in 16 years it failed to start. Gonna head over to the V92c forum and see if I can get some help.
 

·
Premium Member
Joined
·
8,736 Posts
Howdy!

It is probably mad at you for parking it and not racking up some miles on it. Vics like to be ridden.
For sure!...your Vic hates you for putting it in solitary confinement!
Good luck sucking up to it to get back in its good books.
Im off for a ride!:devil
 

·
Registered
Joined
·
9 Posts
Discussion Starter #4
Ok, let’s see if anyone can help. I pull the battery and keep it charges while parked. I put the battery in this morning, turned the key and.... the fuel pump primed like normal, but didn’t shut off like normal. I hit the starter and nothing. No crank at all. Fuel pump still whining away, by the way. Realized no lights lit on the cluster, no headlight, no blinkers, but the horn works. I’m stumped. Checked the fuses and all were good. Not sure if I cooked something hooking up the battery? Battery is fully charged. Any ideas? Sure was hoping for a Father’s Day ride.
 

·
Registered
Joined
·
483 Posts
Is this the same battery you've had? It's 16 years old?

Did you drain the old gas if you had any in it?

Not getting any lights tells me the battery may be dead or some mice chewed your wires. That's only the first two things that come to mind though when thinking about bikes being stored a long time.

You check you plugs, filter, and rubber parts? Probably could use fresh oil too.


As for a Father's day ride I wouldn't be going anywhere on 16 year old tires.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #6
No, this is a two year old Optima gel cel battery. Always do check everything before breaking it out each year. It hasn’t been sitting for 16 years, just didn’t ride it last year. Not worried about old gas or oil at this point. Just trying to get the electrical issue figured out. Thanks.
 

·
Registered
Joined
·
483 Posts
No, this is a two year old Optima gel cel battery. Always do check everything before breaking it out each year. It hasn’t been sitting for 16 years, just didn’t ride it last year. Not worried about old gas or oil at this point. Just trying to get the electrical issue figured out. Thanks.
Gotcha. I misunderstood your first post. Knowing more I read it correctly now.

"Drug it out of the garage and for the first time in 16 years it failed to start."

Being electrical have you checked all the fuses?

I'm also wondering with the fuel pump not seeming to work correctly if it needs replacing. Have you checked if it's actually pumping fuel?
 

·
Registered
Joined
·
9 Posts
Discussion Starter #9
Not sure how to check spark at plugs without the bike having power to the starter. It’s not a failure to fire, it’s a failure to do anything other than prime the fuel pump. It won’t even turn over.
 
1 - 9 of 9 Posts
Top