Victory Motorcycle Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter #1
I recently got my bike back on the road and was running fine... Riding last night and it just died, no warning at all other than sluggish start after running for a bit ... Nothing on now with the key on at all... Battery has juice and checked fuses... absolutely nothing now...
Any help would be greatly appreciated!!!
 

·
Moderator
Joined
·
13,262 Posts
If it just died you need to
Check battery bolts with a 10mm wrench. No your hand is not good enough. If the battery is 3 years old it might be shot.

If battery is good and you have headlight but bike will not start your fuel pump might be shot.

Check to see if you have spark.

Tell us more how it will not start does it turn over.
 

·
Registered
Joined
·
25 Posts
Discussion Starter #3
Battery terminals good... Battery is fairly new... No head light response no electrical on at all totally dead when turned on nothing at all...Checked fuses nothing burnt... Everything seems good... Always check my headlight to see charging and it was good...
Thank you...
 

·
Moderator
Joined
·
13,262 Posts
look inside headlight for bad wire. check ground wire going to motor with a wrench.
 

·
Moderator
Joined
·
13,262 Posts
Maybe your ignition switch failed
 

·
Registered
Joined
·
25 Posts
Discussion Starter #7
I went back through the bike and this time checked the fuses with a test light, the ignition fuse was blown... Now every time I put a new fuse in it blows it...
 

·
Moderator
Joined
·
13,262 Posts
start tracing wire for the bad spot. Look under seat for pinched wire even under gas tank
 

·
Registered
Joined
·
25 Posts
Discussion Starter #11
Found an ignition that supposedly crosses over to a Ford Taurs 96-99 SHO 4.3 Ltr V8 about $100.00 cheaper than Vic dealer... Does anyone know if it will work??? Read on line and it seems feasible...
 

·
Registered
Joined
·
25 Posts
Discussion Starter #12
Tracked down the short... Apparently the wiring harness drooped down and the belt eat into the wires and created a dead short blowing the ignition fuses... They all looked at first but after checking with a test light they were bad...
Thanks for the help...
 
1 - 12 of 12 Posts
Top