Victory Motorcycle Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter #1
Lots of times my neutral light doesn't come on when in neutral. Also my oil light will stay on a few seconds after the bike is turned off. Happens mostly after riding for a while. Any ideas on what can cause this and how to fix? Thanks
 

·
Premium Member
Joined
·
1,863 Posts
On the Oil Light issue: if I turn my 2012 CCT off with the engine kill switch, the oil light stays on a bit. When I hit the Keyless Ignition button, it immediately goes out. I guess something in the way the oil light is wired makes the light stay lit a bit if the engine is turned off by the kill switch.

Neutral Light: I have no clue, mine has never done that.
 

·
Registered
Joined
·
1,485 Posts
+1 to Chattanooga Mark's comments. His experience is the same as mine. Are you able to start the bike in neutral WITHOUT the clutch lever pulled in? If so, then the neutral safety switch is properly functioning and the problem is likely in the neutral light electrical circuit. If the bike will not start while in neutral but without the clutch lever pulled in, then the problem likely lies in the neutral safety switch electrical circuit. Best of luck and please report back on what you find to be the cause of the problem.

G'day,

Vinish
 

·
Registered
Joined
·
19 Posts
Discussion Starter #4
I don't use the kill switch, I use the ignition to turn off the bike. The bike will start in neutral without using the clutch lever. What I haven't tried was to try to start the bike in neutral w/o the clutch lever when then neutral light does not come on. You guys gave me something to think about. Thanks for your input.
 

·
Premium Member
Joined
·
1,863 Posts
Something is off then in your system. When I turn my CCT off with the key (press the keyless ignition button) my oil light never remains on. Only if I turn it off with the kill switch. Like Vinnish said, check your Neutral switch and the light circuitry.
 

·
Registered
Joined
·
19 Posts
Discussion Starter #6
Press the keyless ignition button? I don't think I have that. I probably is the neutral switch. When it the problem comes back. I will take it to the dealer. Hopefully, they will be able to fix. Thanks again for your responses.
 

·
Registered
Joined
·
2,305 Posts
Must be something extra in the XC wiring because I always turn my XR off with the kill switch and my oil light goes off immediately.
 

·
Registered
Joined
·
426 Posts
There is no oil pressure when its turned off. Not abnormal to see it pop on when the engine isn't running.

As for the neutral issue, Ohm it out and check the circuit. Wiring diagrams are all the web. If the wiring is fine get the safety switch replaced.
 

·
Moderator
Joined
·
12,972 Posts
for the oil sender clean it. pull wire off clean the crap out of it. The sender is a unit that been in cars for 20 years.
 
1 - 9 of 9 Posts
Top