Victory Motorcycle Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
hey all, new to the forums, new to victory, not new to bikes lol
i'm in bc canada, bought a high ball to go alongside the sport bike and dirt bike

anybody else have issues with the km/miles display units not staying on the right setting??
 

·
Premium Member
Joined
·
8,946 Posts
hey all, new to the forums, new to victory, not new to bikes lol
i'm in bc canada, bought a high ball to go alongside the sport bike and dirt bike

anybody else have issues with the km/miles display units not staying on the right setting??
Nope my 2010 stays on kms.
 

·
Registered
Joined
·
2,699 Posts
You're probably hitting the function button for the display in your speedometer. Holding it down allows you to change so I suspect it's channging every time you ride. Try rotating your clutch lever a little so you have to reach a bit to get to the button.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #4
You're probably hitting the function button for the display in your speedometer. Holding it down allows you to change so I suspect it's channging every time you ride. Try rotating your clutch lever a little so you have to reach a bit to get to the button.
yeah that's what it would seem like, but i'm not hitting it while riding. i'm following the steps in the manual while stopped, holding the button before turning the key to the on position, clicking and holding through the options, changing it over to km and celsius, but as soon as i cycle the key it reverts back to miles. i can ride and see it's on km, stop the bike while still in km, turn the key off and then back on, and it's in miles. every time. it's not making sense to me. clock stays on the right time, so it's not like the ecm is shutting down....?? i'm lost lol
 

·
Premium Member
Joined
·
1,848 Posts
Welcome from Florida!

Sent from my SAMSUNG-SM-G870A using Tapatalk
 
1 - 5 of 5 Posts
Top