Victory Motorcycle Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
So as stated got a good deal on a 2000 V92C needed a battery and a rear tire replaced, took care of that and it ran good until last night took it out for a spin and it died on acceleration for a lane change, completely dead no gauges no lights nothing, so on further review noticed that Ignition/Flasher fuse (10 amp) was blown, replaced it blew again, so decided to get the van and bring it home, so took a closer look today and made the following observations:
I believe it has some type of aftermarket ECM unit; MBE 4110212 (gold anodized box)
when I install the fuse with the ignition switch in the off position there is a very light ticking noise in the headlight bucket, as soon as I turn the key on it blows the fuse, took off the covers, seat, gas tank, headlight assembly etc to look for shorts didn't find any, so I have a couple of questions:
With that 10 amp fuse kill the power to the bike completely?
It also has What looks like a Breaker mounted to the side cover bracket it's Bosch unit that the main battery lead comes in and out of, but also has a plug that attaches to the side no idea what it's for, and there is no continuity between the terminals (on the breaker) also don't know if that's how it's suppose to be
or if any of you know exactly what this problem is about, I would love a direct answer like it's the breaker or whatever as I have worked on bikes many years, and have done all of the normal checks and observations, just not familiar with fuel injection or the design of Victory motorcycles, I loved riding it the short time it ran, so would love to get it on the road again to see what it does on a daily..Thanks With All my heart to all you people and I'll promise to follow up to help anyone else that might be having this same problem God Bless you All..Thanks
 

·
Registered
Joined
·
12,298 Posts
I'm a Cross bike guy and not familiar with the steel frame bikes, as we call them. But there should be continuity on that main breaker - they are cheap, replace it. I believe its a 40 amp, but remove it and check. You also want the same kind of mounting tabs. Autozone or O'reilly's has 'em - go for the Bussman brand.
There are YouTube vids covering this. Rylan Vos of the Vic Shop has a good one.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
Dude, You guys are Great!! Thank you, I'm gonna change out the breaker and I also downloaded the Manual, Don't know where to find the breaker, but I'll start the research tonight again Thanks for the Replies and the Help..
 

·
Registered
Joined
·
12,298 Posts
Dude, You guys are Great!! Thank you, I'm gonna change out the breaker and I also downloaded the Manual, Don't know where to find the breaker, but I'll start the research tonight again Thanks for the Replies and the Help..
Scroll up to post #2. Sheesh!
 

·
Registered
Joined
·
4 Posts
Discussion Starter #7
Guys you've been GREAT!!! Thanks for all the help, Turns out the problem was a busted right turn signal bulb, I have NEVER seen a Bike shut off and play dead the way this did due to a busted indicator bulb but i guess you live and learn, replaced the bulb no more blown fuse started right up...AGAIN Thanks for ALL the Great advice You guys don't know how much I appreciated it..
 

·
Registered
Joined
·
973 Posts
The bike shouldn't shut down due to a bulb circuit shorting to ground. I'm not familiar with the 92's but it sounds like a previous owner changed something. Take a look at the wiring diagram if the download included them and I'm pretty sure you will see a fuse in the circuit. If there isn't, add one.
 

·
Moderator
Joined
·
13,185 Posts
Jefecito

where did you come up with aftermarket ECM idea. Can you post a photo of it. Have never heard of any thing like this
 

·
Registered
Joined
·
4 Posts
Discussion Starter #10
The bulb had fell apart into pieces and the filament was grounding out on the housing not sure the what's or the why's but replaced it and started right up, I'll check the diagram but everthing looks stock, I came up with the aftermarket ECM unit because I looked on Ebay for one and ALL the ones for that year didn't match the shape or the mounting of the one on the bike, but looking at the diagram it shows its the stock unit bu the shape and size of it shown there, so we are all good..Thanks soooooo much for all you guys help and off to ride a bit as soon as it clears up a bit..God bless you all
 
1 - 10 of 10 Posts
Top