Victory Motorcycle Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
211 Posts
Discussion Starter #1
Yesterday I traded my 09 Vegas for a NOS 2012 XR. Took the bike on it's maiden voyage today and with 145 miles on the odo, the speedo went a little crazy. The gear indicator, cruise control and speedo stopped working intermittently. A quick search revealed others with speed sensor problems. I'll be taking it back to the shop Monday since it's still under warranty, but I'm curious, a bad sensor on a brand new bike? BTW, loved the ride, and the bike.:D
 

·
Registered
Joined
·
4,091 Posts
Its one of those "quirks" the bikes have, sorry it happened to you on the first day of ownership...Don't get down on the bike yet, give it a chance.
and what's NOS?
 

·
Registered
Joined
·
2,407 Posts
NOS= New Old Stock. In other words he bought an untitled 2012 XR so it is considered a new bike.
 

·
Registered
Joined
·
211 Posts
Discussion Starter #4
Took it to the dealer this morning and they replaced it on the spot. Back on the road grinning.cheers
 

·
Registered
Joined
·
203 Posts
Good to hear!
 

·
Registered
Joined
·
611 Posts
glad its all sorted. just a reminder to everyone that no matter how good a manufacturing process is, bad parts still get made from time to time. And no matter how good the inspection process is, those bad parts can make their way out the door. It sucks to be on the receiving end of one, but there is no reasonable way to ensure only 100% good parts get shipped.
 
1 - 6 of 6 Posts
Top