Victory Motorcycle Forum banner

1 - 17 of 17 Posts

·
Registered
Joined
·
263 Posts
Discussion Starter #1
i have 600 miles on new 2014 xc and i just noticed the oil light stayed on after i removed the key for a second or two... right after my 500 mile service. i checked oil, fine, then called shop and mechanic told me that happens sometimes on these bikes... any of you guys have this happen? it doesnt do it all the time intermitant. thanks
 

·
Moderator
Joined
·
12,984 Posts
pull wire off sending unit and clean it. The sending unit is right behind the end of the kickstand if it was up.
 

·
Registered
Joined
·
1,365 Posts
Mine stays on too and it's intermittent ... meaning sometimes I notice it, other times I don't :ltr:
 

·
Registered
Joined
·
160 Posts
Mine doesn't do it, a light staying on after bike is turned off is not normal. Because it is a commen problem aperantly, doesn't mean it is suposed to do it. Would you accept the dealers answer if it was your truck doing the same thing?
 

·
Registered
Joined
·
223 Posts
This is a shot in the dark. Your bike may have a capacitor for the radio or iPod. This may be discharging power back into the system for few seconds. Note it's not suppose to do that. Ask your tech to look into it.
 

·
Registered
Joined
·
263 Posts
Discussion Starter #14
well said all, of course it didnt do it when i told him it did it, thats when the" they all can do that" came out. ill try the sending unit clean and hope it does it in the presence of the tech otherwise ill pretend its supposed to do that... thanks guys.
 

·
Registered
Joined
·
636 Posts
pull wire off sending unit and clean it. The sending unit is right behind the end of the kickstand if it was up.
. Mine does it too..... Had it back to the dealer...... Told them.....they didn't do a damn thing.....cuz it still does it.....intermittently. So clean the sending unit connection you say? The good thing is that advice won't cost me $85.00 like the dealers investigation did..... Thanks VJ.... I'll check that out.
 

·
Premium Member
Joined
·
1,865 Posts
On my 2012 CCT, the oil light comes on for a few seconds if I turn the bike off with the kill switch. If I turn it off with the key, the oil light doesn't come on.

Been that way since day one.
 

·
Registered
Joined
·
66 Posts
My '14 XC shows the same behavior as Chicago Mark's.

Kill Switch turn off = oil light on for a second or two.
Key off= no oil light

Can repeat, each and every time.
 
1 - 17 of 17 Posts
Top