Victory Motorcycle Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I took my 2011 Victory Vision Tour home from Ohio to Buffalo, NY area and I cannot believe the Polaris Dealership in Medina were I purchased it actually put me on a bike that needed the brakes bled. I pressed the peddle down and there was NOTHING. Went to the bottom until I pumped it several times stopping just inches behind a tractor trailor truck that had jammed his brakes on in a construction area.
But thats not even all of it!
While traveling and using the Cruise Control the speedometer swung back and forth from zero to 200 several times while the gear indicator glitched flashing all numbers randomly while this happened.
After it all stopped I had no speedometer it stayed at zero and I had no gear indicator, although the fuel, temperature and neutral light came in while in that.
I tried using the cruise control several times thinking it may be a short? But nothing, the cruise light flashes for a moment on, and then goes out.
Meanwhile the mileage indicator stayed the same during the careful but risky rest of the trip home.
Some have suggested there is a sensor that could be the culprit that causes this and it either failed or has dirty connections.
Does anyone here have a photo or schematic of where such a device might be and if so, is it a big job to replace or get to it to clean it?
Glad to be aboard! Just joined today and looking forward to getting to know members here.
Gaia...
 

·
Registered
2012 Victory Cross Country Tour, Indianapolis
Joined
·
3,337 Posts
That many problems you should have turned around and taken it back.
 

·
Registered
Joined
·
468 Posts
This is the one for a 2002 V92C Deluxe
Try witchdoctors or cheapcyleparts.
They have a very useful and extensive parts manual for your year and model.
My sensor cost about $140.

they are easy-peasy to replace.
One bolt secures it.
Reaching in to the connector requires fingers a foot long, but is easily done with the correct coarse language.
Cant do it when pipes are hot, unless you are superman of course.

Any questions?

253447
253448
 

·
Registered
Joined
·
9 Posts
I just replaced mine in my 2013 Vegas 8 ball, similar issue; no speedo or gear indicator. If you look at the left side of the bike as you would sit on it, behind the engine on top of the transmission is where the speed sensor is. As stated above, 1 bolt and a wiggle it comes out. Took me about 5 minutes to switch. Pop the slclip off, remove bolt, put sensor in, install bolt, and replace clip. Super easy, should have no issues at all. Make sure the bike is cool, you will burn your hand if it is hot.
 
1 - 4 of 4 Posts
Top