Victory Motorcycle Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hey new to this site,
Looking for some advise and help with my V92TC Cruizer.

The problem is that the Speedo is acting up on my bike. What is happening is that the (MFD) Multi function display is going blank along with the speedometer and the Tach are freezing at what ever the speed is and when they are working all is fine. BUT usually find that MFD and speedometer and tach all go at the same time, prematurely and do not know what to do to solve this problem ?

Just wondering what do to solve this problem or is there a replacement speedo to get to replace this one. Victory does not make this part anymore. Not sure what to do to repair this problem ?

Any suggestion ??

René
 

·
Registered
Joined
·
71 Posts
Hi, Rene.

Sounds like a loose connection somewhere. The reason I say that is because, if I understand correctly, the system works intermittently. The turn signals on my 04 v92tc stopped working and I assumed it was the Turn Signal/Hazard Flasher. I set about testing the thing and then lost all fire to the turn signal bulbs. I checked wires and connections for some time and one day, while working on the bike and talking to my wife the lights came back on. They did not blink but came back on. SHORT. The first harness I had moved was the one connecting to the Flasher. After a quick look I saw the ground wire broken at the connector. Some solder and a replacement Turn Signal/Hazard Flasher and I was back in business.

It helps to have the manual.

You may be able to find a used working speedo on eBay, but they are often pricey.

Good luck with it. A friend who was an electrician once told me that all mechanics think electricity is magic. To which I replied, "Yes! And we don't like it".

Warm regards,
Doug
 
1 - 3 of 3 Posts
Top