Victory Motorcycle Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
1,120 Posts
Discussion Starter #1
I have only had my XCT since January. But oh say a month or so ago the radio reception seems to have got worse. Now local station wont even come in very clear. The display sometimes shows the station call letters and artist and song. But I would say more times than not nothing shows. And the reception is bad. Is this something that maybe the dealer can correct with a firmware update or something. I know the reception on my RSV was not that great either, but at least I could get the local stations in town.
 

·
Premium Member
Joined
·
13,166 Posts
Since it was better at one time and not long ago; I'd be thinking something on the bike has changed. Maybe a connection issue where the antenna plugs in or something between there and the head unit (stereo).
 

·
Registered
Joined
·
1,120 Posts
Discussion Starter #3
Yup my first thoughts too. I was under the fairing installing some charging cables and fixing a loose wire issue and installing the plug for the bluetooth output. It was a week or better after that. But still I went back in to see if maybe something got disturbed. I took the antenna apart, cleaned it and installed some dielectric grease. No better. It does have the short antenna, but it has been there from the git go.
 

·
Registered
Joined
·
812 Posts
my radio is way worse when I have the ipod olugged in.
 

·
Registered
Joined
·
1,120 Posts
Discussion Starter #5
my radio is way worse when I have the ipod olugged in.
HMMM thats odd. Maybe I'll unplug it and see if it changes things for me. Thanks for the heads up. Seems weird it would do that, but I suppose if you got the ipod plugged up you probably aint gonna need the radio.
 

·
Premium Member
Joined
·
538 Posts
my radio is way worse when I have the ipod olugged in.
Same here... I unplug it around town and get decent reception (also shorty antenna), but when I get out of town I use the iPod so I pull of and plug it in
 

·
Registered
Joined
·
131 Posts
I solve bad radio reception by using my phone and Bluetooth to log into the station of choice; I have unlimited data. Other than that, a longer antenna would help and if using any added led lights, try turning them off.
 

·
Registered
Joined
·
75 Posts
HMMM thats odd. Maybe I'll unplug it and see if it changes things for me. Thanks for the heads up. Seems weird it would do that, but I suppose if you got the ipod plugged up you probably aint gonna need the radio.
I had a similar problem.

The 12v to usb adapter I was using just killed the FM radio reception. Come to find out its a common thing. Google it.
It took me several tries at the local auto parts store to find one that worked properly.
Had the same problem in my truck as well.
 

·
Registered
Joined
·
1,120 Posts
Discussion Starter #10
I had a similar problem.

The 12v to usb adapter I was using just killed the FM radio reception. Come to find out its a common thing. Google it.
It took me several tries at the local auto parts store to find one that worked properly.
Had the same problem in my truck as well.
So the 12v adapter may be source of problem? I grabbed power right off the current plug in fairing on back side.
 

·
Registered
Joined
·
1,120 Posts
Discussion Starter #11
Finally disconn the ipod. I think it got a little better reception on a ride today. Still had on and off display of the "song" on the screen. Maybe it is just the station I have on does not xmit that info all the time or something. So there may be some relevance to this thought.
 

·
Registered
Joined
·
27 Posts
I was having the same issue. The radio was working fine all last season then all of a sudden no more reception
except local stations and that wasn't very good. checked the connections at the back of the radio still no reception
so I took apart the connection on the antenna, cleaned the paint off the antenna bracket were the cable ground connects
and also cleaned any place the cable connected to the antenna. Now the radio works like it use too. I think it a bad ground
connection because Ma Vic depends on these little sharp taps to make a connect thu the paint. Hope this helps, GOOD LUCK.
Ride safe.
 
1 - 12 of 12 Posts
Top