Victory Motorcycle Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
209 Posts
Discussion Starter #1
I've got XM radio, which I listen to most of the time vs other options, FM/AM, aux,,, Sometimes, when I get back on the bike and restart, when the radio boots up, it's back on XM 1,, not where I left it.
Doesn't seem to matter if I turn off the radio first before turning off the bike. Not the biggest of deals, one button push on a preset and it's back to my preset.
 

·
Premium Member
Joined
·
430 Posts
How old is your battery AND we should make stickers that say "check your battery connections" :laugh

Our radios draw a tiny bit as well as the ECU even when off. All modern vehicles do. If you get a weak cell in the battery or a bad connection at the post the radio loses the current and reverts to a preset during the high amp draw of a start.
 

·
Registered
Joined
·
209 Posts
Discussion Starter #3
How old is your battery AND we should make stickers that say "check your battery connections" :laugh

Our radios draw a tiny bit as well as the ECU even when off. All modern vehicles do. If you get a weak cell in the battery or a bad connection at the post the radio loses the current and reverts to a preset during the high amp draw of a start.
nice try.
Changed battery as I didn't know it's age and was starting to turn the motor over a bit slower than it used to. Never had a charger on it in two years as I ride it all year. Still happens on the radio, but I think it may be more of a xm signal loss such as in the garage or riding next to woods or under a bridge. Not really sure but not a big deal at this point.
 

·
Moderator
Joined
·
13,003 Posts
where do you have your antenna and is it a xm one.
you might want to go to dealer and ask for a flash
 
1 - 4 of 4 Posts
Top