Victory Motorcycle Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
84 Posts
Discussion Starter #1
Not sure how many folks have the reverse gear in their XCT, but I opted for it, mostly to avoid hernias trying to back up on a hill.

Had it put in when I got the bike two years ago, and it's worked very well. Recently, I've had two times that I used it and things got difficult.

In neutral, switched the gear on, then used it to back the bike up. Stopped, flip the gear off, but the electronics think the bike is still in reverse. Pretty much nothing I can do. If I put it in gear, the engine dies (by design) because it thinks the gear is still engaged.

Turn key off, back on, "R" still flashing.

Takes about 15 minutes of turning off and on, popping gears in and out, wrestling the bike around while in gear before the electronics FINALLY realize the reverse gear isn't engaged, and I can move on.

Anyone else have similar experiences?

Thanks!
 

·
Premium Member
Joined
·
6,029 Posts
Can't help you / hope you can fix it / subscribed / and just for info (maybe you know already) this is how the vic reverse ring looks like ... uploadfromtaptalk1448985269046.jpg
 

·
Registered
Joined
·
790 Posts
Once mine did a similar thing. They had to tow it in, and fixed it for free, luckily! It happened soon after install.

What we both learned:

1: make sure the engagement rod is properly aligned
2: don't forget to lube per the Vic service manual
3: NEVER force it into gear. If it doesn't go easily "rock" the bike forward and back slightly and it will drop in. (Feels kind of like the gears aren't exactly aligned.)
4: Never take it out of gear unless fully stopped.

And yes LOVE the reverse.
 

·
Registered
Joined
·
304 Posts
Yes, need insight! I am getting the kit and installing hopefully over Christmas. Any tricks of the trade so to speak would be good! Thanks!
 
1 - 5 of 5 Posts
Top