Victory Motorcycle Forum banner

1 - 6 of 6 Posts

·
Premium Member
Joined
·
49 Posts
Discussion Starter #1
I have searched the threads, but cannot find any that address my issue. I have a 2011 Kingpin, it had a stage 1 kit & x-bow pipes.

I had a dealer install the S&S and reflash. Now my bike pings terrible when you get on it in all gears, or if you lug it at all. I have had to burn reg gas before and never had these issues !

I just got back from a 400 mile run and burned any old gas out and always burn prem gas. The plugs are burning fine ????????

The dealer has installed lots of these and says no problem.

Has anyone had these issues ??
 

·
Registered
Joined
·
156 Posts
Try searching "pinging" there are several threads about it. Basically, S&S downloads suck bad.
 

·
Registered
Joined
·
263 Posts
Here is a recent thread where someone had the same problem as you. Reading it scared me away from getting the download done, instead I bought a fuel controller like he recommended. http://www.victoryforums.com/showthread.php?t=10566
I think this is going to be an ongoing problem for lots of people. I'm beginning to come to the conclusion that fuel controllers are pretty much a necessity on any bike (Victory or other) that has a modern design if you're going to add any performance options to it, and completely avoid reflashes of the ECU. Everyone isn't adding the same intakes, cams, baffles, or pipes, so what makes them think a single reflash download will be appropriate for all? With the way these engines perform I think you're FAR better served to have your destiny in your own hands through a fuel controller than to place it in the hands of some reflash download that you have no idea of how they came to their conclusions about what SHOULD work best on a thousand different bikes with a thousand different configurations.

If I could do it all over again I would have had the dealer install my fuel controller at that same time as he added my pipes and air intake when I took delivery of the bike and never have had a flash of the ECU done.
 

·
Premium Member
Joined
·
29 Posts
I just went through the same problem. Get the fuel controller. It solved all of the pinging and rough running problems. This problem drove me crazy and cost me several hundred dollars and several trips to the shop and it still wasn't fixed. Good luck!
 

·
Premium Member
Joined
·
49 Posts
Discussion Starter #6
Hi Folks

I took it back to dealer and they found a faulty o2 sensor. Took it for a test ride and no pinging.

Hope to go for a good ride this weekend and give it a good test.
 
1 - 6 of 6 Posts
Top