Victory Motorcycle Forum banner

21 - 40 of 44 Posts

·
Premium Member
Joined
·
2,451 Posts
Im convinced theres a direct link between the cruise not working and the sabretooth lights.
Its a fact that when theyre unplugged at the saddlebag connections the cruise control becomes fully operative.
And when the sabretooths are plugged in the cruise wont work.
Sad...cos itd be nice to have both...at the same time.
You probably need a resistor in there somewhere to make the load on the circuit equal to what it is without the additional lights. The manufacturer should be able to help with that.
 

·
Registered
Joined
·
1,668 Posts
Wouldn't a resistor ADD load not take it away? It sounds like your hypothesis is that the Sabertooth lights are an additional load that prevents the cruise from working properly. They are certainly an additional load since they are additional lights. They do not replace any existing lights. If this is correct, then you would need an "anti-resistor" not a resistor. That is, you would need something that reduced load on a circuit and I do not think such a device exists.
 

·
Premium Member
Joined
·
8,992 Posts
Now Im really confused....
wonder......Do we have a resident electrics guru on this website
 

·
Registered
2012 Victory Cross Country Tour, Indianapolis
Joined
·
1,755 Posts
Maybe it's a 2010 thing? My 2012 doesn't care.
Could be a wiring issue too maybe need to compare to the kuryakyn wire harness.
 

·
Premium Member
Joined
·
8,992 Posts
Maybe it's a 2010 thing? My 2012 doesn't care.
Could be a wiring issue too maybe need to compare to the kuryakyn wire harness.
Are yours Kuri or Chinese(suspect same origins anyway)
I had to scalpel a plastic location peg off the grey harness connector so itd slot in, ...wires all line up...lights all work ok....just cruise wont work.
Off on my big trip Tuesday so Ill be using cruise...daytime running mostly so extra lights will be unplugged...
 

·
Registered
Joined
·
798 Posts
Maybe it's a 2010 thing? My 2012 doesn't care.
Could be a wiring issue too maybe need to compare to the kuryakyn wire harness.
I have a 2010, with cruise, sabertooth that come on with the brakes and it doesn't affect my cruise...what did cause my cruise grief was the 1/4 turn on the throttle ...that messed with my cruise took that off and my cruise problems went away.

Ride Safe,

Rob
 

·
Premium Member
Joined
·
8,992 Posts
I have a 2010, with cruise, sabertooth that come on with the brakes and it doesn't affect my cruise...what did cause my cruise grief was the 1/4 turn on the throttle ...that messed with my cruise took that off and my cruise problems went away.

Ride Safe,

Rob
Is your Sabretooth Kuri or Chinese?
have no 1/4 turn on the XC
 

·
Registered
Joined
·
798 Posts

·
Registered
2012 Victory Cross Country Tour, Indianapolis
Joined
·
1,755 Posts
Perhaps they tap the wrong wires in that Chinese harness. Or something in the LED lights used is causing it.

Tempting to use one of those trailer wiring adapter isolators. Then the saber can be turn and brake lights. :cool:
 

·
Registered
Joined
·
156 Posts
I've got the Kury ones and they do not affect my cruise. Also, there was no tab to shave off on the connector like the Chinese ones have
 
  • Like
Reactions: CanuckRob

·
Premium Member
Joined
·
8,992 Posts
Thinks Id better consult an auto electrician.
 

·
Registered
Joined
·
1 Posts
found the discussion and want to bring some light. I bought the chinese set (just because were cheaper and sold by amazon), took almost a month to get here and YES, the connector is not exact, you have to pill off a small tab. Didn't realize right away the issue with the cruise control. The lights look awesome and work excellent, but when the cruise control stopped working, I took it to the dealer since I have warranty and it took them almost 3 weeks to figure out it was the light (they change the whole cruise control module, wires, grounding). They say the lights "confuses" the onboard computer to think the breaks are applied always and cruise control wasn't engaging.
End of story, bought Kuri ones (more than double the price of the chines one) and the connector fits perfectly (no need to pill anything) and my cruise control works no problem.
I have a Victory Cross Country 2016
 

·
Registered
2012 Victory Cross Country Tour, Indianapolis
Joined
·
1,755 Posts
Just need to figure out what the Chinese ones are doing on the wiring harness. Tapped wrong wires or something odd.
From your post maybe missing a diode so it's feeding running light power back into brake wiring.
 

·
Premium Member
Joined
·
8,992 Posts
Just need to figure out what the Chinese ones are doing on the wiring harness. Tapped wrong wires or something odd.
From your post maybe missing a diode so it's feeding running light power back into brake wiring.
Itd be great to find a cure as Im not about to go and pay double for genuines ( effectively triple cos already got the chongos!)
I just disconnect sabres when going on a big long freeway ride, which is boring and rare.
And daylight too I might add.
Most of the time Im never on a constant speed so the lights are enabled.
If its just a diode, like on the Stebel horn, then Im in for a fix.
 

·
Registered
Joined
·
1,146 Posts
I could probably get away with the Chinese ones. I have a trailer light controller and would just slave them in on that. Before I got the trailer light thing I added some small side running lights and everything was cool. When I added a lighted bar for my cooler rack to put the travel bag on it would pop fuse. To much draw. So these CAN buss systems are finicky about power
 

·
Registered
2012 Victory Cross Country Tour, Indianapolis
Joined
·
1,755 Posts
I could probably get away with the Chinese ones. I have a trailer light controller and would just slave them in on that. Before I got the trailer light thing I added some small side running lights and everything was cool. When I added a lighted bar for my cooler rack to put the travel bag on it would pop fuse. To much draw. So these CAN buss systems are finicky about power
That was my thought. Use a trailer kit and have the Chinese sabers be brake AND turn lights. :)
 

·
Registered
Joined
·
66 Posts
Discussion Starter #37
Itd be great to find a cure as Im not about to go and pay double for genuines ( effectively triple cos already got the chongos!)
I just disconnect sabres when going on a big long freeway ride, which is boring and rare.
And daylight too I might add.
Most of the time Im never on a constant speed so the lights are enabled.
If its just a diode, like on the Stebel horn, then Im in for a fix.
You were right about the diode. Thanks to someone in the Victory Facebook group, I have cruise control again. There is bleed back voltage from the saber tooth lights on the brake light wire (brown wire in the plug for the saber tooth lights). So I added a diode on that wire.



Sent from my iPhone using Tapatalk
 
  • Like
Reactions: Motorbikerx

·
Premium Member
Joined
·
8,992 Posts
You were right about the diode. Thanks to someone in the Victory Facebook group, I have cruise control again. There is bleed back voltage from the saber tooth lights on the brake light wire (brown wire in the plug for the saber tooth lights). So I added a diode on that wire.



Sent from my iPhone using Tapatalk
Cool!..Thanks! What size diode?
 

·
Registered
Joined
·
66 Posts
Discussion Starter #39

·
Registered
Joined
·
66 Posts
Discussion Starter #40
I bought one of the fuse type diodes from the auto parts store



Sent from my iPhone using Tapatalk

This is the pic the guy on Facebook sent me, so you can see the diode in the fuse holder


Sent from my iPhone using Tapatalk
 
21 - 40 of 44 Posts
Top