Victory Motorcycle Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
46 Posts
Discussion Starter #1
So here's the story: My engine decided to run a little off since my last oil change, and it had some popping issues while at speed. I thought that it needed a little tuning for my altitude, so I followed the guidelines for enrichening/leaning out the fuel trim on the Vic Shop tutorial. My bike now is running worse than ever. Surges and stalls at idle, and no matter what I do to it it won't even out. I have the PMRT chip installed, and it was doing fine minus the popping issue until the oil change. Running 5.5qts of Victory oil.

My question is this: is it possible to reset the ECU back to the condition the chip was shipped in? Is it simply resetting the baseline on the TPS? I'm planning on dropping the tank and cleaning my throttle body and visually checking my throttle plates for the proper setting. in case i set it way wrong. Also will be checking TB boots for cracks.

I need to get this bike running well by saturday, so any help would be appreciated.
 

·
Super Moderator
Joined
·
6,372 Posts
The first thing I would do is undo your changes and see if it starts running better. If not, check your battery connections.
 

·
Premium Member
Joined
·
8,836 Posts
The first thing I would do is undo your changes and see if it starts running better. If not, check your battery connections.
Seconds those ideas.
 

·
Premium Member
Joined
·
1,572 Posts
Undo changes, clean TB's, check for vacuum leaks, reset tps.
 
1 - 5 of 5 Posts
Top