Victory Motorcycle Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
has anyone experienced this problem i have a 09 8 ball bought it new
couple months ago and ever since evertime i accelerate from a stopped position it shudders i thought it would go away after break in but thats not the case...
 

·
Registered
Joined
·
87 Posts
What is shuttering? Bars? The whole bike? Is your belt loose? Have you given the bike a good going over and make sure everything is tight? I found 7 loose bolts on my new 8ball when I got it home. 2 were on the front end, 3 motor mounts and 2 swingarm bolts. They were not loose but were not tight to specs.
 

·
Registered
Joined
·
59 Posts
has anyone experienced this problem i have a 09 8 ball bought it new
couple months ago and ever since evertime i accelerate from a stopped position it shudders i thought it would go away after break in but thats not the case...
never had that problem... cus' I dont ride a polaris.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #4
The whole bike shudders, i have gone over most bolts and they seem tight the belt is tight the wheels forks etc. all tight almost seems like the clutch chadder....

yes doc, we know you don't have a victory your compensating for your small penis with a harley good for you...your probably the kinda guy who walks around with a picture of there bike on there shirt with the slogan get'er done!
 

·
Registered
Joined
·
59 Posts
The whole bike shudders, i have gone over most bolts and they seem tight the belt is tight the wheels forks etc. all tight almost seems like the clutch chadder....

yes doc, we know you don't have a victory your compensating for your small penis with a harley good for you...your probably the kinda guy who walks around with a picture of there bike on there shirt with the slogan get'er done!
Not get'er done.... it says, Sausage King.
I had a similar problem, believe it or not.... HD do have issue once in a blue moon. Damn bike shuddered like the engine was going to come off the motormounts. Turned out to be a busted backet that holds up my exhaust and the same bracket is connect to my hard bag supports. The vibration went clear up to the engine.
 
1 - 5 of 5 Posts
Top